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Overview
ApolloOne is a powerful image viewer and digital asset manager designed for the seasoned
amateurs and professional photographers. The design objectives are ease of use and speed
- lots of it. Arguably the fastest image viewer ever created for the macOS, it works with
your existing folder structure without ever needing to import files into a database. It offers
a comprehensive set of tools for the photographers: smart memory card imports, displaying
camera AF points, rating and culling images, managing metadata, searching and filtering
using metadata, batch rename, and much more.

To take full advantage of the software, we recommend reading the following sections of this
guide to help setting things up: Configure Places, Metadata Setup, Importing files from
memory card and Enable trash put back.  There are many options available under
Preferences (or Settings) to help you configure the appearance and behavior of the app.

What's new with version 3.8.0:
Apple RAW Decoder support for Fujifilm GFX100RF.
Adds support for 14-bit Olympus ORF files.
Adds AF Point support for Nikon Z5 II.
Adds Sigma .X3F support for the memory card import process.
Underexposure fix for Fujifilm uncompressed RAF file with DR200/400.
Bug fix for file index reset when tagging files in filter mode.
Updates LibRaw to version 202502.
Updates ExifTool to version 13.29.
Updates MediaInfo to version 25.04.
Various improvements and bug fixes.

What's new with version 3.7.4:
Bug fixes.

What's new with version 3.7.3:
NEW! Adds the ability for user defined shortcut keys for changing color tag and rating.
NEW! Add Folder to Places context menu.
Adds the ability to disable Navigation Panel under Advanced Settings.
Bug fix for Canon .CR3 decoder.
Work around Apple RAW Decoder bug for Leica M Monochrom DNG image under macOS
Sonoma and Sequoia.
Updates ExifTool to version 13.25.
Various improvements and bug fixes.

What's new with version 3.7.2:
Updates ExifTool to version 13.18.
Bug fixes.

What's new with version 3.7.1:
NEW! Navigator panel to show an overview of the image when performing image zoom
and pan.
Allows Overexposure and underexposure display for any images1.
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Desktop wallpaper

Fluid Swipe mode

Reopening the last viewed file
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Additional keyboard shortcuts

Special User Defaults

Requirements and limitations

Revision history

Updates ExifTool to version 13.17.
Improvements and bug fixes.

What's new with version 3.7.0:
NEW! Adds contrast, saturation and vibrance controls in the RAW Adjustment panel.
NEW! Overexposure and underexposure display for RAW images1.
NEW! AF Point support for Nikon Zf, Z50 II and Z6 III1.
NEW! Auto hide mouse pointer in full screen mode.
Updates ExifTool to version 13.12.
Various improvements and bug fixes.

Click Revision history to see the full list of changes.

1. Requires Subscription or Perpetual License for Standard Edition.

2. Requires Subscription or Perpetual License for Pro Edition.
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Standard Edition
Pro Edition (in addition to the features of the
Standard Edition)

Display AF points and camera detected faces Split View with synchronized image zooming and
scrolling

Batch Rename Browsing History with Split View support

Batch operations (set GPS coordinates, image rotation,
change EXIF file creation dates, remove metadata, etc.)

Batch Image Resize and format conversion; copy/move
and resize images at the same time

Image cropping Batch Image Export, including HEIC format

Edit EXIF, Makernotes and some common XMP/IPTC data
fields directly in the Inspector Import files from memory cards with resume feature

Most editing functions under Camera / User Metadata User customizable Favorite Tags for the Inspector

Viewing of image and video aliases Filter files by searching metadata tag contents, including
Regular Expression matching

Folder Browser can resolve folder aliases Filter files by existing keywords found in image/video
files

Shuffled playback for slideshow with background music
support using Apple iTunes/Apple Music

Filter files using GPS Distance Measurement and GPS
Altitude

Add new IPTC / XMP tags Measure distance of two images using GPS coordinates

Sort by User Defined Sequence Synchronize XMP sidecar file to image

Refresh All Thumbnails (with multi-core processing) Export 16-Bit TIFF and PNG file formats

Keep sort settings on a per folder basis Record slideshow output to a video file

Sort images randomly Attach, replace metadata using templates

Overexposure and underexposure display for RAW
images User customizable Shortcut keys

Display compressed Fujifilm RAF files using Apple RAW
Engine (higher visual quality)

Display HE/HE* compressed Nikon NEF files

The free download version of ApolloOne gives you unlimited access to many useful features for image and video browsing,
plus limited editing of metadata. To try out all the features of the Pro Edition, you can start the 14-Day free trial. After the 14
days trial period, it will be downgraded to the free version. You can subscribe to either the Standard Edition or the Pro Edition.

Below is a list of features available in the Standard Edition and Pro Edition:

Free version vs Standard and Pro Subscriptions

Users who have paid for the previous version 1.x or 2.x will automatically receive a perpetual license for the Standard Edition,
and can subscribe to the Pro Edition with 50% off the regular yearly subscription fee.



ApolloOne organizes access to local and network folders under Places.

To configure Places, you need to turn on the folder Browser. You can turn on the Browser by pressing the ⌘N key or by selecting
the menu item under "Tools > Show Browser".

When ApolloOne is first launched, the Pictures and Downloads folders are the default items in Places. You can browse images and
videos within these folders.

By adding folders to Places, you are merely granding the access of the folders to ApolloOne. ApolloOne does not require importing
any folders. Apple App Store policies require user's explicit consent of folder access before the contents are accessible.

You can add a folder to Places by clicking the "+" button in the Places section of the Browser. Select the "Folder" menu item.
Select the folder (including network folder or disk volume) you want to add to Places. You can add as many folders as desired.

You can group related places by adding a separator item.

You can rename a place item by double clicking the item, and type in a new name. When you are finished typing a new name,
press the enter key. This only changes the display name, but will not change the actual path to the folder. To see the actual folder
path, simply hover the mouse pointer over the place item, a tooltip will be displayed, showing the actual path.

You can delete a place item by clicking the "-" button.

You can rearrange the items in Places. Click on the item you want to move. While holding down the mouse button, drag the item
up or down in the Places list. When the item is at the desired position, release the mouse button.

If you want to add a disk volume to Places, please follow the instructions at the end of this section.

Adding Smart Folders  (Finder Saved Searches) to Places
When you perform a search in Finder, you can save the search result as Saved Search (Smart Folder). You can later access this
Smart Folder and retrieve the files matching the search criteria.

The search results are normally saved under ~/Library/Saved Searches. You can add this folder to Places, and ApolloOne will
have access to the previously saved search results. The search results will appear as a Smart Folder.

NOTE: we recommend you save or copy the Finder search results in a separate folder, one that you want to use with
ApolloOne, and add that folder to Places instead. Or you can save Finder search results to an existing image folder,
ApolloOne will treat this saved search result as a Smart Folder.

Adding Disk Volume to Places
From the add Folder dialog box, locate the disk volume by browsing your Mac, (we have "Bladerunner-i9" in this case), and select
Macintosh HD.

If you have renamed the default "Macintosh HD" to something else, please select that name instead.

Configure Places



Select the "Macintosh HD" and click the OK button.



ApolloOne allows you to set the source of the Metadata, so that you can work efficiently with Finder or other 3rd party
applications. There are three Sources to choose from:

Use macOS Extended Attributes (allow Finder searches)
Use this option if you want to be able to perform searches using Finder on the metadata. In this mode, only the Extended
Attributes of a file is changed, the file itself is never touched when you change any of the fields in the "Edit Metadata" panel.

Use XMP (allow compatibility with 3rd party applications)
Use this option when you want compatibility with 3rd party applications that use IPTC/XMP tags.

When this option is selected, only five standard XMP Labels colors are used: Red, Yellow, Green, Blue and Purple. When
changing the state of the Red tag, for example, ApolloOne will save or remove the word "Red" in the XMP:Label metadata tag.
The Orange and Gray color tag will be hidden, as these values are not applicable to the XMP:Label tag.

Changes with Star Rating will affect the XMP:Rating tag. The allowed values are -1 (Reject), 0 (Unrated) and Rating 1 to 5.

Combine both settings
When this option is selected, both of the meta settings in the above will be used. However, files will be tagged with custom
labels (if defined), while the XMP:Label tag will always be tagged with a color value (ie: Red) to ensure 3rd party apps
compatibility. The Orange and Gray color tag will be hidden, as these values are not applicable to the XMP:Label tag. You will
not be able to tag with these two colors as Finder color tags when this option is used. And only one color tag is saved to file's
Extended Attributes.

Which Metadata Source should I use?
For most Mac users, the "Use macOS Extended Attributes" is sufficent, and it allows quick searches of images using Finder.
Extended Attributes are transferrable together with the file through the use of iCloud, but they may be lost if some other cloud
services are used.

For more sophicated users, who use 3rd party applications that use IPTC/XMP metadata for managing images, or uses cloud
services other than iCloud, it would be more appropriate to select "Use XMP" setting.

For the power users who want the best of both worlds, select "Combine both settings".

Note on changing Metadata Source
You can select a different Metadata Source anytime you want, however, it is possible to introduce inconsistencies. This
inconsistency can affect all metadata fields.

If you have selected "Combine both settings", updating the Keywords, for example, will simultaneously update
IPTC:Keywords, XMP-dc:Subject and the file's extended attribute holding the Keywords metadata. And if you update the
Comment field, it will simultaneously update XMP:UserComment and the file's extended attribute holding the Comments
metadata.

If you edit the metadata directly from the Inspector, only that particular metadata is changed. For example, if you changed
XMP:Label from Yellow to Green, only the XMP:Label tag is changed, the file will not be tagged with a Green Finder tag.

If you edit the metadata with the "Edit Spotlight Metadata" panel in the Inspector, changing the "Spotlight Keywords" and
"Finder Comments" fields, the IPTC:Keywords, XMP-dc:Subject, XMP:UserComment tags will also be updated if Metadata
Source is set to "Combine both settings".

Resolving Inconsistent Finder color tag / XMP:Label:

If you tagged a file with a Red Finder tag with the "Use macOS Extended Attributes" setting, and then tag the same file again
with a Yellow Label with the "Use XMP" setting, you created an inconsistency.

When you select "Combine both settings", ApolloOne will combine both metadata sources and both color dots will be
displayed.

Metadata Setup



Now if you decided to toggle the Red tag off, ApolloOne will turn off the Finder Red tag in the extended attributes, but the
XMP:Label content Yellow will be left unchanged.

Instead of turning the Red tag off, you decided to turn on the Green tag. ApolloOne will turn on the Finder Green tag in the
extended attributes, remove the Yellow tag from the extended attributes, and replace the XMP:Label content from Yellow to
Green. The resulting file will be tagged with Green.

Resolving Inconsistent Rating tag:

If you tagged a file with a 3-star Rating with the "Use macOS Extended Attributes" setting, and then tagged with same file
again with a 4-star Rating with the "Use XMP" setting, you created an inconsistency.

When you select "Combine both settings", ApolloOne will try to resolve this inconsistency by taking precedent of the Rating
metadata from the XMP:Rating tag over the extended attributes Rating metadata.

In fact, any non-empty metadata found in IPTC/XMP tags will take precedent of the file extended attributes mapped to the
same tag.

Now if you decided to update the Rating to 5-star with "Combine both settings", both the extended attributes and XMP:Rating
will be changed to a value of 5.

Synchronizing with Finder labels
You can synchronize the label texts used in Finder with ApolloOne. When you first start ApolloOne, it will ask you to give
ApolloOne access permission to your home folder. If you have given ApolloOne the access permission, it will be able to
synchronize the labels used by Finder. For example, you renamed the label "Red" to "Landscape" in Finder, ApolloOne will be
able to pickup that change, and use the same label name when tagging. This is the preferred method to ensure everything is
synchronized.

If you do not give ApolloOne the access permission during app start, you can add this later by checking the setting "Sync with
Finder labels" under the "Preferences... > Metadata" page, and give ApolloOne access permission to your home folder.

NOTE: If you renamed the labels in Finder, ApolloOne will automatically retrieve the new labels. It may take up
to 30 seconds for macOS to save the new label values to disk before ApolloOne can read them. This delay is due
to the caching of the file system. For macOS Monterey and up, you will need to restart ApolloOne in order for the
new label names to take effect.

Define custom labels
You can define custom labels in ApolloOne so that they match with the custom labels you set in Finder. Or you may want to
correct some inconsistent labelling issues by using custom label definitions. You can configure the labels under "Preferences...
> Metadata" page.

Finder's default color labels are set to Red, Orange, Yellow, Green, Blue, Purple and Gray. The color of the dot and the
wording of the label matches. That is, a red dot corresponds to the word "Red" saved in the file's extended attributes.

When ApolloOne writes the word "Red" to the file's extended attributes, it will show up as a red dot next to the file in Finder.

Suppose you use a custom Finder color tag with the label "Important" to signify some important files you are working on. If
you define custom label of the red dot in ApolloOne to the word "Important", ApolloOne will write the word "Important" when
you set the red dot ON in ApolloOne.

By doing so, you can have ApolloOne toggle the Important tag on and off, matching the Important tag in Finder.

Please note that you may have "Important" using an invisible color dot in Finder. If you set the red dot in ApolloOne to
"Important", a red dot will be shown in ApolloOne, yet the dot is invisible in Finder. It is recommended you set the custom tag
in Finder matching the same dot color in ApolloOne to avoid confusion.

When Metadata Source is set to "Combine both settings", changes to color tags in ApolloOne will be applied to XMP:Label
simultaneously. This means, if you turn on the red dot in ApolloOne, the word "Red" will be written to XMP-xmp:Label
metadata tag. This allows 3rd-party applications compatibility, should you require managing the files between ApolloOne and
another application.



ApolloOne offers a file import process to help you copy image files and video files from memory cards to your SSD or other
storage locations. The import menu items can be found under the File menu.

Please note that the location of the RAW files copied depends on the user preference "Additional subfolder name to search for
RAW files:". Please see the preference setting here for more detail.

Import Files...
This is a simple 3 steps process for importing files.

Step 1: A dialog box prompts you for the location of the memory card. Please select the path to the memory card and not any
subfolder inside the memory card. This allows the import process to traverse all subfolders to discover any new files for copying
to your destination folder. Click the "Next >" button when you are done with the memory card selection.

NOTE: If you have performed an import using the same memory card previously, you will be offered to resume from the last
import file location. Select YES to resume from the last import. The process will scan your memory card to find the next file for
importing. If there is no newer file to import, the import process will end. If newer files are found, Step 2 will be skipped and
you will be prompted to Step 3 to create or select the import destination folder.

Step 2: The first file you want to start copying. This can be an image file (JPEG, HEIF, TIFF, camera RAW file) or a video file.
This is the first file the import process will copy. All files with newer datetime stamps will be copied to the destination folder.
After seelcting the file, click the "Next >" button.

Step 3: Select the destination folder to import the files to. This can be a folder on your boot drive, an external HDD or a network
folder.

Finally, an options dialog is shown for the various import options before proceeding:

Importing Files from Memory Cards



Import from:

This is typically the path to the memory card.

Start from:

The first file that will be copied. A thumbnail of the file is also shown below.

Copy to:

The destination folder in which the files will be copied to.

Do not import files after:

This option lets you select the file date in which import should copy up to. The date shown is the date of the selected file in
"Start from:". If you enable this option and keep the date unchanged, then only images created on that date will be copied.

Include JPEG / HEIF / TIFF Files

Copy JPEG, HEIF and TIFF file types. Uncheck this if you do not wish to copy the JPEG / HEIF / TIFF files.

Include RAW Files

Copy RAW files. Uncheck this option if you do not wish to copy the RAW files.

Include Video Files

Copy video files. Uncheck this option if you do not wish to copy the video files.

Overwrite Existing Files



Files in the destination folder with the same filename will be replaced with files in the memory card with the same name.

Rename Duplicate Files

Rename the file being copied if destination already contains a file with the same filename.

Play sound when complete

Play sound when the import process has completed the copy process.

Eject memory card when complete

Eject the memory card when the import process has completed the copy process. It will check to ensure the Import from:
location is a removeable device before it ejects the disk.

The import process saves all the parameters you used and remembers the location of the last imported file. When you start
"Import Files..." process the second time with the same memory card, it will ask you whether you want to resume from the last
file location. If you clicked "Yes", you will be prompted to select the destination folder, skipping step 1 and 2. Only files newer
than the last import process will be copied.

Delete originals from memory card

The original files imported from the memory card will be deleted once the import process has complete. It moves the files to the
Trash so you can still recovery them if necessary. To permanently delete the files, you need to empty the Trash.

Advanced Option >>

Click the button to open the Advanced Options pane. The settings in Advanced Options are saved automatically so that the same
settings are restored in the next import run. The Advanced Options are not in effect at the time of import if the Advanced Option
pane is not opened when you click the GO button.



Create Subfolders

Files are grouped by date by placing them inside subfolders with names set to the date format selection. Example above has
date format set as YYMMDD. ApolloOne checks the file's EXIF:DateTimeDigitized or EXIF:DateTimeOriginal metadata tags
and move the files to the subfolder with the same date.

Rename Files

There are three selections: None, Custom Text + Sequence and Batch Rename Template.

If None is selected, it will not rename the files and it will just copy them as-is from the memory card.

If Custom Text + Sequence is selected, you can specify a prefix text plus a starting sequence number. For example, you can
specify Custom Text as Tokyo_ and Sequence number of 0001. The files will be renamed as Tokyo_0001.JPG,
Tokyo_0002.JPG, etc. The Sequence number is fixed at 4-digit.

If Batch Rename Template is selected, you can select a batch rename template you created with the Batch Rename process.
You can click the Define Rename Template button to create or edit a batch rename template on the fly.

If Preserve original filename in XMP is checked, ApolloOne will save the original filename in XMP:OriginalDocumentID
tag, regardless of the Metadata source selection under "Preferences... > Metadata".

Add Metadata

There are three selections: None, Basic and Metadata Template.

If None is selected, it will not add any metadata to the imported files.

If Basic is selected, you can specify the Creator name and Copyright information. These metadata will be written to the files



during the Import process.

If Metadata Template is selected, you will have 2 additional options. Load Metadata Template will let you load any .xmp
files and add the metadata defined in the .xmp file to each imported file.

You can also define a metadata template on the fly by clicking the Define Metadata Template button. This will bring up a
dialog similar to the Edit Metadata window. Only metadata defined in this dialog box can be added to the imported files.

Import from the Current File...
This is a slightly modified import process with a different workflow. It assumes you have added the memory card to Places, and
you are browsing the folders in the memory card in Contact Sheet mode. When you have identified the first file you want to
import, select that file and use "Import from the Current File...". This will skip step 1 and 2 and you only have to create or select
the destination folder to start the import process. Please note that this process will only copy files in the folder where the
current file resides.



When you move a file to the Trash (or Bin), the Put Back feature is only available when the file was trashed via Finder. This
feature is generally not available to other Mac applications.

However, ApolloOne does support "Undo Move to Trash" function so that you can use it to move the deleted files from the
Trash back to the original locations. This only works while ApolloOne is running. Once you have quit ApolloOne, the deleted
files will remain in the Trash, and you will have to copy or move them back to the original locations yourelf.

It is possible to enable the trash item "Put Back" feature so that you can easily recover the delete files back into their original
locations.

In order to enable this feature in ApolloOne, a user script needs to be installed. This script tells Finder to trash the file, so that
you can use the Put Back feature to recover the file.

To enable Trash Put Back, go to "Preferences... > Startup & Delete". Click the "Install" button to install the user script. It will
prompt you to download the user script from our website. Proceed to our website to download the script. Follow the
instructions on our website. This procedure is needed to comply with the App Store standard.

The user script needs to be installed under "user name > Library > Application Scripts > com.anogeissus.ApolloOne" folder;
where "user name" is the name of the current logged-in user. In most cases, ApolloOne will have this folder selected for you.
Simply click OK to install the script. If you have granted Home folder access during app initialization, the install process will
simply install the script without prompting you the location of the folder to store the script.

After the user script is installed, you will be prompted to add ApolloOne to "System > Security & Privacy > Accessibility".
Please add ApolloOne under Accessibility to allow it to control Finder for the file delete and undo operations.

If the user script is not installed, ApolloOne will use the normal process to move the files to the Trash. You can still recover
the files by "Undo Move to Trash" while ApolloOne is running.

Enable Trash (Bin) Put Back



How to Setup Shortcut Keys
You can customize the shortcut keys under "Preferences... > Shortcut Keys".

Expand the menu, such as File and find the menu item where you want to modify the shortcut key.

For example, you want to modify the Open... menu item. Double click on that entry and you will see the flashing prompt to tell you to press a new shortcut
key.

Press and hold the ⌥ (option/alt) key and then press the letter O.

Repeat for other menu items where you want to change the shortcut keys. If you encounter a shortcut key that is already used by another menu item, you
will be prompted to replace that shortcut key or cancel and try again.

Once you are satisified with all the changes, click the button "Activate New Shortcut Keys" to activate the new shortcut keys.

Shortcut keys with a combination of modifier keys
You can add keyboard modifiers to the shortcut key. The modifier keys are ⌘ (command), ⌥ (option/alt), ⌃ (control), ⇧ (Shift). fn (function) key cannot be
used as a modifier key.

Not all combinations of modifier keys are possible. macOS disallows some combinations of modifier keys and/or shortcut key. Some combinations of these
keys are reserved by the macOS or used by ApolloOne and cannot be changed.

If a combination of keyboard modifiers and shortcut key do not work as expected, it maybe reserved by the macOS. You should choose a different shortcut
key and modifier keys instead.

List of ApolloOne reserved shortcut keys
1. ⌥↑ ⌥↓ ⌥← ⌥→ (keyboard panning of a zoomed image)
2. esc (to exit shortcut key capture mode)
3. delete or backspace key (to remove shortcut key for the menu item)
4. ↑ ↓ ← → (arrow keys)
5. spacebar (move to next image)
6. ⌘[ ⌘] (previous image and next image for 3rd party mouse support)

User Customizable Shortcut Keys





You can set an additional subfolder for storing your RAW files.

Typically, most users would store the RAW files alongside with the JPEG files in a subfolder. A subfolder could be given the name of an event, like "Vacation
to Tokyo". This is the default behavior for ApolloOne.

However, you can choose to separate the RAW files from the JPEG files by putting all the RAW files inside a subfolder under the current folder where you put
your JPEG files. So your RAW files are placed separately inside a subfolder, something like: "Vacation to Tokyo/RAW".

You can define the name of this subfolder under "Preferences... > File types > Additional subfolder name to search for RAW files:".

If you want to go back to the default behavior, leave the name of the RAW subfolder blank.

By putting a name for the RAW subfolder, certain operations will behave differently. They are: importing files, copying and moving files from one subfolder
to another.

"Import Files..." will put the RAW files in the RAW subfolder during the copy process from the memory card. Copy and move operations will move all RAW
related files to the RAW subfolder if this folder exists in the destionation subfolder.

Additional Subfolder for RAW Files



ApolloOne has a very high performance file pre-loading and file caching subsystem. It does background read ahead and read
behind with concurrent I/O. When the cache is full, it performs cache entries replacement using an adaptive LRU (Least
Recently Used) cache replacement policy.

When ApolloOne is first started, the default cache size is set based on the amount of memory installed. For most systems with
8GB of memory, the default cache size is set to 8. In Auto mode, the cache can resize dynamically based on the location of
the images, which determines how much processing concurrency should be used.

For example, if you are browsing a slow network device via Wi-Fi, the cache size and thread concurrency will reduce to cope
with the limited network bandwidth.

Cache size can be manually adjusted from 4 to 32. This represents the number of images being cached.

When processing RAW images, ApolloOne can dynamically increase the cache size to increase performance. This is based on
the number of processor cores and whether the images are located on a SSD.

If you would like to change the cache size manually, you can do this under "Preferences... > Advanced > File cache". Uncheck
"Auto" and adjust the slider to increase or decrease the cache size.

File Cache Setup



ApolloOne uses the GPU (Graphics Processing Unit) to speed up the display of images. By default, it trades display speed over
quality. You can improve image quality by turning on the "High quality image scaling" setting in "Preferences... >
Appearance".

When this setting is turned on, all image scaling will use Lanczos filtering for the highest possible display quality1. On newer
Macs with faster GPU hardware, this will give you high image quality without sacrificing display speed.

If loading images become slow, turn off this setting and use the default fast image scaling instead.

1. Lanczos filtering is not available in Fluid Swipe mode.

2. Lanczos filtering has little visual improvements for high resolution images on Retina Display. It is recommended to turn this
setting off on Macs with Retina Displays.

High Quality Image Scaling



You can set ApolloOne as default application for a particular file type.

If you want to set ApolloOne as the default application for opening JPEG files, open Finder, locate a JPEG file and right click or
control-click on the file to bring up the context menu.

Select "Get Info". From the info page, change "Open with:" to ApolloOne. Then click the "Change All..." button to register
ApolloOne as the default application for the file type.

Set as Default Application



ApolloOne has a file system monitor that can detect folder content changes.

When you open a file, it will start monitoring the folder where the file resides. If you move files in and out of that folder (such
as moving files to the Trash), or edit a file using an external application, ApolloOne will synchronize the display and
thumbnails once the files have completed the write to that folder.

You can even drag a subfolder to the folder being monitored, and all the files in the subfolder will be synchronized to
ApolloOne. But in order to do that, you must have the "Include Subfolders" setting enabled under the Tools menu.

ApolloOne will only synchronize the file types that you have specified under "Preferences... > File types".

In addition, ApolloOne monitors folder changes for the current selected place. When you add, rename, or delete a folder using
Finder, ApolloOne will refresh the folder tree automatically. The only exception is when you create a folder alias using Finder.
In this case, you will need to manually refresh the folder Browser by bringing up the Browser's context menu, and select
"Refresh".

Notes: Dropping a large number of files into a monitored folder can impact the performance of ApolloOne and/or the system.

Folder Monitor



ApolloOne has four display modes: Combine JPEG+RAW, Files other than RAW, RAW Only, and All Files.You can only
select one of the four Display Modes.

When ApolloOne is first started, the default Display Mode is Combine JPEG+RAW. When you open a folder with a mix of
JPEG and RAW files, the JPEG and RAW files will be combined into a single thumbnail for display. The JPEG file will be the one
displayed for the combined pair.

Single RAW files (RAW files without corresponding JPG files) are displayed automatically in Combine JPEG+RAW mode.

For HEIC file, it is possible to pair it with a DNG ProRAW file with iPhone Pro models.

Files other than RAW mode will display all image files found in the folder except RAW files. In other words, all image files
except RAW files and video files will be displayed.

RAW Only mode will display all RAW files found in the folder, all other image files and video files are excluded from the
display list.

All Files mode will show all files in the folder. This includes all image files and video files.

Combined JPEG+RAW Processing

When Combine JPEG+RAW display mode is turned on, certain processing will be applied to both the JPEG and the RAW files.
These are:

Finder tags/Color Labels
Star Ratings
Adding and deleting GPS Coordinates
Setting EXIF Digitized Date
Shifting EXIF Digitized Date
Restore Image to Original

Selecting Display Mode



You can use ApolloOne's "File > Open..." and "File > Open Recent" menu items to open and view photos or videos.

You can also drag-and-drop multiple files and folders into the main viewing window or the Dock icon and ApolloOne will scan
all the folders for support file types and exclude files that are not supported for viewing. If you want to scan the subfolders
when you drag-and-drop a folder into the main window, you need to include the subfolders by selecting "View > Include
Subfolders" from the application menu.

Thumbnails are generated on the fly using multi-core parallel processing, this process can finish very quickly. Thumbnails are
stored as a highly compressed JPEG in a database. ApolloOne periodically runs a scavenger thread to inspect the thumbnail
database and removes thumbnail entries without a corresponding image file in the original locations.

If you have enabled ApolloOne as the default application for the image file type (such as JPEG), you can simply double click on
the file and ApolloOne will be launched. The file scan process will include all photos and video files in the current folder for
viewing.

You can exclude certain file types you do not wish ApolloOne to scan for. Open "Preferences... > File types", uncheck the file
types you do not wish to be included in the file scan process.

Note: ApolloOne will open all supported file types regardless of the above setting if you select a file from the "Open..." menu
or open them via the drag-and-drop operation.

Image with transparent background
ApolloOne will display a checkerboard pattern as image background if an image with transparency is detected.

RAW image preview engine
ApolloOne has a high speed RAW image preview engine that can render a preview of the RAW image almost instaneously.
Certain DNG files may not support this feature, and ApolloOne will attempt to decode the RAW file to present you with a
preview image. In this case, the time required to decode and display the image will be substantially longer.

Viewing image aliases
macOS allows you to create alias files in Finder. When an alias file is created, macOS adds the " alias" to the file extension. In
order for ApolloOne to display the alias file, the file name should not have " alias" in the file extension. This assume you want
the alias file to exist in another folder, instead of the same folder where the alias file is created.

Symlink files are create using Termina with the ln command. If you use the ln command, the symbolic link of the file can also
be displayed by ApolloOne.

NOTE: The support of alias files and symlink files require Full Version Upgrade.

Zooming images
You can zoom in and zoom out of an image by pinching on the Trackpad or by using the keyboard. A navigator panel will
appear to show you the overview of the image during zooming and panning. To zoom in and out using the keyboard, press the
shortcut keys - and =. The + key on a keyboard equipped with the numeric pad can also be use to zoom in the image. The
keyboard zoom increases or decreases the magnification by 5% linearly each time you press the key. You can hold down the
modifier key control (^) and the magnification is increased or decreased by 5% in terms of number of pixels.

You can instantly zoom to a particular magnification by holding down the control (^) key and press the numeric keys: 1, 2,
3...9, where 1 corresponds to 10% linear magnification of the image, and 9 corresponds to 90% linear magnification. Pressing
Z gives you 100% magnification, which is the actual image size with 1:1 pixel mapping.

You can hold down the modifier keys alt (⎇) and control (^) and press one of the numeric keys and the magnification will be
based on image resolution. For example, if you have a 16Mpix image, pressing ⎇^5 will give you a 8Mpix image (50%
reduction of the image resolution). Where as pressing just the ^5 key will give you a 4Mpix image (50% reduction in both
horizontal and vertical dimension of the original image).

You can restore to the viewing default (zoom to fit) by pressing the shortcut key F on the keyboard or the * key on the
numeric pad.

Viewing Photos



You can toggle the current zoom magnification to 100% magnification and vice versa by selecting the "Zoom Toggle" menu
item under View or by pressing the shortcut key Z on the keyboard.

If you have a Magic Mouse or 3rd party mouse with a scroll wheel, you can zoom in and zoom out by holding down the alt key
and move up and down on the surface of the Magic Mouse with your finger or scroll the mouse wheel.

Zoom snapping points
When you zoom in and out of an image using the Trackpad or mouse, the realtime zoom snaps to and pauses momentarily to
let you know that you have reached a snapping point. The snapping points are: image fitting the window, 100%, 200% and
400% magnifications.

Panning images
You can pan around a zoomed-in image by using the Trackpad, Magic Mouse or keyboard. To pan using the keyboard, hold
down the alt key and press the arrow (direction) keys.

Maintaining zoom and pan position when viewing images

ApolloOne maintains the image zoom and pan positions when viewing across images of the same resolution1.

When image is zoomed in, you can pan around with the Trackpad or Magic Mouse. You can also pan around with any mouse
by simply holding down the primary mouse button and pan the image around.

In order to view the next image with the same zoom and pan position with a Trackpad or Magic Mouse, you need to hold down
the Command ⌘ key and swipe the Trackpad or Magic Mouse.

You can also do this anytime with the keyboard by pressing the arrow keys.

1. This feature is not supported in Fluid Swipe mode.



ApolloOne has built-in support for viewing HEIC and HEVC (H.265) media.

HEIC and HEVC are the new High Efficiency Image Coding and High Efficiency Video Coding formats developed by the Moving
Picture Experts Group (MPEG). They allow image and video files to be encoded in roughly half the size compared to JPEG and
H.264 without the loss of quality. Currently, HEIC images (.HEIC) and HEVC encoded videos (.MOV) can be obtained by
images and videos taken with Apple iPhone 7, 7 Plus, 8, 8 Plus, X, iPad Pro and later devices running iOS 11.

In order to import photos and videos on the Apple iDevice with the new encoding format, you need to set your iDevice to
transfer to Mac or PC in the new formats.

On the iDevice running iOS 11, open Settings.
Select the camera icon, select "Formats > High Efficiency". All photos and video taken from now on will be in High
Efficiency format.
Select the Photos icon, under "TRANSFER to MAC OR PC", select "Keep Originals".
Connect your iDevice to the Mac via the Lightning port.
Open the Image Capture app in Applications.
Select the images with HEIC file extension. HEVC videos have the same MOV file extension.
Click Import.
Open ApolloOne to view the imported files.

Viewing HEIC and HEVC Media



ApolloOne has a built-in camera RAW decoder.

The built-in RAW decoder can handle RAW files from the majority of digital camera brands and models.

It can process Fujifilm compressed RAF and Nikon HE/HE* compressed NEF images and send them through the Apple RAW
Decoder pipeline for enhanced image processing.

As of July 2024, ApolloOne stands out as one of the few premier software applications capable of processing
Nikon HE/HE* compressed NEF files and Fujifilm compressed RAF files using the Apple RAW Decoder. Access to
these exclusive features are restricted to users with a Pro Edition perpetual license or an active Pro subscription.

When "RAW > Use Embedded JPEG Preview Image" is turned off, this will enable the built-in RAW Decoder.

When "RAW > Use Embedded JPEG Preview Image" is turned on, ApolloOne retrieves the embedded JPEG preview image in
the RAW file so you can quickly view the RAW image.

By default, ApolloOne uses the Apple RAW Decoder to ensure the best image quality. If the RAW image is not supported by
the Apple RAW Decoder, the software automatically falls back to the LibRaw Decoder.

You can turn this setting on or off under the menu "RAW > Use Apple RAW Decoder when possible"

When the RAW Decoder is able to use Apple RAW Decoder to render the image, you will see [AppleRaw] in the title bar next to
the file name. Otherwise, you will see [LibRaw] instead.

You can also customize the Toolbar to include the "Use Apple RAW Decoder when possible" button, and quickly toggle the
Apple RAW Decoder on and off.

In situations where the embedded JPEG preview image is unavailable or its resolution is insufficient, the built-in RAW decoder
will step in to generate the image directly from the RAW file.

Should ApolloOne encounters a new RAW file format that it does not recognize, it will seamlessly revert to using the
embedded JPEG preview image.

You can also turn on the Adjustments Panel to help with the assessment of the RAW image. The settings in the Adjustments
Panel have no effect on JPEG or when the "Use Embedded JPEG Preview Image" is turned on.

Please note that Fuji Film Simulations and Nikon Picture Control are not used when displaying the RAW images.
For example, if you take the photo in monochrome, the RAW file will be displayed in color by either the Apple
RAW or LibRaw Decoder.

RAW Adjustments Panel
The RAW Adjustments panel offers a few simple settings to help you evaluate a RAW image. They are:

Exposure (EV) compensation (-2EV to +2EV)
Highlights adjustment (0% to 100%)
Shadows adjustment (25% to 100%)
Temperature (2000K to 10000K)
Tint (-150 to 150)
Contrast (0 to 2)
Saturation (0 to 2)
Vibrance (-1 to 1)
Unsharp mask radius (0.1 to 5.0)
Unsharp mask amount (0% to 500%)
Auto Tone Curve (On or Off)

You can click on any of the adjustment values and manually type in new values. Press the enter key after inputting a new
value.

You can double click on the slider knob to reset the slider to the default value.

You can turn on the Overexposure Display and Underexposure Display under the Tools menu to help with adjusting the

RAW Processing



Highlights and Shadows values.

You can tag the image while making changes with the Adjustment Panel. This includes color labels and star ratings.

Details on RAW processing
To optimize performance when using the decoder, the RAW decoder is configured to generate a half-size image from the RAW
file. For instance, if the camera resolution is 6000x4000 pixels, the RAW processor will create a 3000x2000 image from the
RAW file. Subsequently, it scales the image back up to the original 6000x4000 resolution using a high-quality Lanczos filter.

If you need to export the RAW image via Export Image File function, you may want to turn off "Decode image at half-size for
speed" setting under the "RAW" menu to ensure maximum image quality.

The RAW decoder built into ApolloOne is not a full-fledged RAW converter with many adjustment features. However, it does
provide a quick assessment of the content of a RAW file.

The initial value for Color Temperature is obtained via the embedded MakerNotes metadata. If such information is not
available, it will be set at the default of 6500K.

If Apple RAW Decoder is used, Color Temperature and Tint will be obtained from the Apple RAW Decoder instead.



While you are browsing images and videos with ApolloOne, it generates and retrieves thumbnails in the background. The
thumbnails are presented as a strip of "positive film" or "color slide film" that is placed across the bottom the window. You can
place the film strip across the top of the window by setting a user preference. Open "Preferences... > Appearance" and check
the "Put preview thumbnails across the top of the window" setting.

You can put the thumbnails in a grid like a picture Gallery by switching on the Contact Sheet mode. You can do this by
selecting the menu item under "View > Contact Sheet", pressing the shortcut key C (with the main image display in focus), or
simply click the Contact Sheet button on the Toolbar.

To adjust the size of the thumbnails, just hover the mouse pointer above the center location of the film strip, a handle bar will
appear. Grab this handle bar and move it up or down to adjust the size of the thumnails and film strip visually.

You can also resize the thumbnails in Contact Sheet. Move the zoom slider on the Toolbar to adjust the size of the thumbnails.
Thumbnail size is adjusted independently in the Film strip and Contact Sheet.

ApolloOne generates high resolution thumbnails from the image and stores them as compressed JPEGs in a database. If a
thumbnail is found in the database, it will be retrieved and displayed immediately.

ApolloOne manages the thumbnail database for you; orphaned thumbnails are removed automatically when the corresponding
files are deleted. This includes deleting files from Finder even when ApolloOne is not running.

Preview Film Strip



ApolloOne can display the AF points and detected human faces metadata stored in the image files.

Due to the complexities in supporting these functions, not all camera brands or models are supported.

Camera brands with "Show AF Points" support are: Canon, Nikon, Fujifilm, Olympus and Sony.

Camera brands with "Show Detected Faces" support are: Canon, Fujifilm, Nikon, Panasonic, Pentax, Olympus and Sony.

In addition, ApolloOne will use the GPU to detect faces in the image if there are no Faces metadata in the image. This must
first be enabled using Terminal as described in Special User Defaults.

When you have enabled "Show AF Points" or "Show Detected Faces", you can cycle through the AF points or detected faces at
100% magnification by pressing the [ and ] shortcut keys. The first or primary AF point will be shown in green and the rest of
the AF points shown in white. The first detected face (or primary face) will be shown in yellow and the rest of the detected
faces shown in white.

The "100% Zoom" and "Zoom Toggle" functions also automatically center the first focus point or the first detected face when
"Show AF Points" or "Show Detected Faces" are enabled. Magnification preference is given to the first detected face when both
functions are enabled.

Show AF Points and Detected Faces



ApolloOne has the ability to playback Apple Live Photo.

Live Photo consists of an image file (usually a JPG or HEIC image) plus a short video file (a MOV video) with the same file
names. ApolloOne will treat the pair as one file and display a Live Photo badge on the image display window to signify the
image is a Live Photo.

To playback the Live Photo, just hover your mouse pointer to the Live Photo badge (with the word LIVE in it), and you will see
the Live Photo playback.

If the Live Photo's orientation is incorrect, you can rotate the image by 90 degrees using the rotate menu items under the
View menu.

You can obtain Live Photo by exporting the Live Photos from withing Apple's Photos application.

Open Photos, select "File > Export > Export Unmodified Original for x Photo...", where x is the number of Live Photos you are
exporting.

Click the Export button, a dialog box shows up for selecting the folder where you want to export the Live Photos. Select the
folder and click the "Export Originals" button.

Live Photo Playback



A video controller is available when playing back videos. It is shown in HUD-style. There are a few options available for the
video controller.

Note: If you are using OS X 10.12 Sierra or later, the AirPlay button is available. You can send the video display via Wi-Fi to
the Apple TV or another AirPlay compatible device.

Shortcut keys
The Space bar plays and pauses playback.
The right and left arrow keys step frame-by-frame through the video.

JKL navigation:

The J key rewinds. Press it multiple times to cycle through rewind speeds.
The K key stops playback.
The L key fast-forwards. Press it multiple times to cycle through fast-forward speeds.

To navigate to the previous or next media file when a video is playing, hold down the command (⌘) key and press the left or
right arrow key.

Options menu
Use SRT Subtitle: select this item to use the SubRip SRT subtitle function. The subtitle file needs to have to same name as
the video file, but with SRT file extension. This setting is ignored if SRT subtitle file is not found.

Only UTF8 Unicode and plain text files are supported. Accented characters are also supported. If the SRT file is not recognized
in either of these formats, subtitle texts will not be displayed.

Use Frame Stepping Controls: select this item will change the Forward and Rewind buttons to Frame Stepping control
buttons. The Frame Stepping control buttons allow you to perform single frame advance so you can position the frame
accurately for exporting.

Export Video Frame as JPEG...: this menu item allows you to export (save) the current video frame as a JPEG file. It will
save the exact frame as you have positioned with the Frame Stepping controls.

Video Playback



ApolloOne has a slideshow mode that runs though all the photos and videos from the current file scan.

You can start the slideshow anytime by clicking the "Start Slideshow" menu item from the Tools menu, or by clicking the
Slideshow button in the Toolbar or by pressing the F5 function key.

You can stop the slideshow anytime by clicking "Stop Slideshow" menu item from the Tools menu or by clicking the Slideshow
button in the Toolbar or by pressing the esc or the F5 function key.

You can change the delay between slides time interval by using the up and down arrow keys while slideshow is in progress.
Each press will add or subtract 0.5 secounds to the interval.

You can also use a Laser Presenter such as the Logitech R400 to start, stop and navigate within slideshow.

You can shuffle slideshow playback by clicking the "Shuffle Playback" menu item from the Tools menu or the context menu.
This feature is available to Standard Edition or Pro Edition users.

You can customize the behavior of the slideshow. Open "Preferences... > Slideshow" and check on the various settings.

When slideshow encounters a video file, it will play the video file for the duration of the setting Delay between slides. But
you can have it configure to plaback the entire video if you have enabled the setting Playback the entire video before
showing next slide.

Note: The transition effects of the slideshow are accelerated by the Graphics Processing Unit (GPU).

Slideshow controller and configuring slideshow music playback
When the slideshow is running, a slideshow controller is available for pausing and manually running the slideshow. The
controller is shown as a HUD style hovering panel. When you move the mouse pointer within the main image display window,
the controller will show up.

If you paused the slideshow, you can still manually run the slideshow by clicking the skip ahead and skip backward buttons on
the slideshow controller. You can also use the left/right arrow keys, or by swiping left and right with the Magic Mouse or
Trackpad to move to the previous or next slide. You can quickly pause or resume the slideshow by pressing the spacebar.

Slideshow



You can configure background music playback when running the slideshow. Click on the musical note button on the slideshow
controller and a popover will be shown. The popover shows a list of playlists from iTunes. Select any playlist and click the play
button on the popover to play the music items in the playlist. Or you can select an individual music item for playback as well.
You can make a playlist as default by clicking the checkmark next to the playlist. Once you have set a default playlist, the
music will be played automatically when you start the slideshow.

The popover can be detached as a separate floating window. Just drag on the title "iTunes Playlists" or any blank area in the
music controller (the lower part of the popover). Once it is detached, you can click the miniaturize button to toggle the music
controller in and out of miniaturized mode. The music controller operates as a separate floating panel, so you can drag it
around, start or stop the music independently regardless of whether the slideshow is running or being put on pause.



ApolloOne supports the scanning and thumbnail display of Affinity Photo (.afphoto) and Pixelmator (.pxd) files.

Affinity Photo .afphoto file and Pixelmator files are not an open file standard. However, ApolloOne is able to display the
thumbnail using QuickLook, and use the thumbnail as the image display.

You can remove the scanning of .afphoto files and .pxd files under "Preferences... > File types".

Affinity Photo (.afphoto) and Pixelmater (.pxd) Files Support



ApolloOne can playback voice memos recorded by the camera. You will most likely find the voice memo feature on
professional DSLRs or professional mirrorless cameras. The voice memo file is simply a WAV file with the same file name as
the JPEG or camera RAW file.

When a voice memo is detected, the "Play Voice Memo" menu item will be enabled under the Tools menu. If you have the
"Voice Memo" button on the Toolbar, the button will also be enabled when the voice memo is present.

Simply select the "Play Voice Memo" menu item or click the "Voice Memo" button on the Toolbar. You can pause and resume
voice memo playback by clicking the Voice Memo button or the menu item.

You can also play, pause, resume voice memo by pressing the shortcut key ⌘V.

Voice Memo Playback



ApolloOne has the ability to view two images or videos side-by-side via Split View.

Split View can be activated by choosing it from the View menu ("Split View > Activate") or by pressing the shortcut key
option-V.

To select the view, just click the left or the right view or by pressing the tab key on the keyboard. The selected view becomes
the primary view and is enclosed with a focus ring. All actions performed from this point on will be applied to the image in the
primary view.

You can also activate Split View by selecting two thumbnails in the Contact Sheet, and then select Split View from the menu.

When Split View is active, you can select a different image in the primary view. This can be done by using the left/right arrow
keys, or by selecting another thumbnail in the filmstrip or in the Contact Sheet.

You can select a different image in the secondary view by using command+mouse click in the filmstrip or in the Contact
Sheet.

You can change both images in Split View at once by switching to Contact Sheet, select two thumbnails, and then switch back
to image viewing mode. This is achieved by single mouse click on the first thumbnail and command+mouse click on the
second thumbnail.

You can continue to tag, rate, delete, filter and crop photo in each view of the Split View.

Synchronized Scrolling and Zooming
Synchronized scrolling is activated automatically when both images in the Split View are zoomed in (magnified). The selected
view will be the primary view in which both images will scroll in lock step as you scroll the magnified image on the primary
view. You can scroll with a Magic Mouse or Magic Trackpad.

To zoom both views with the Magic Mouse, hold down the option key and glide up and down on the surface of the Magic
Mouse.

You can zoom both views simultaneously by holding down the control key and pressing the shortcut key Z (for 100% zoom)
or the shortcut key G (for 200% zoom). You can zoom to fit both images by pressing the shortcut key control-F. The shortcut
keys = and - can also be used to zoom in and zoom out both images at once. You can scroll the image around by holding the
option key and pressing one of the arrow keys.

When you zoom the image in the primary view, the image in the secondary view will zoom with the same magnification. You
can change the zoom ratio on the primary view by holding down the command key and perform pinch zoom with the
TrackPad. As soon as you start zooming without holding down the command key, the image in the secondary view will snap
to the zoom ratio of the primary view.

You can adjust the origin of the secondary view by scrolling the image with the mouse pointer hovering in the secondary view.

For users with third party mouse, you can perform synchronized scrolling by dragging the image in the primary view. To
adjust the origin of the image in secondary view, hold down the command key, and drag the image in the secondary view.

NOTE: For third party mouse with a scroll wheel, please turn on the setting under "Preferences... > Advanced > Zoom image
with mouse scroll wheel" so that you can zoom the image with the mouse scroll wheel.

Toobar Items
There are additional Toolbar items that can be configured to help with using Split View.

Split View: This toolbar item toggles the Split View on and off.

Swap Views: This toolbar item swaps the two views in Split View.

Sync Views: This toolbar item sets the secondary view to the content of the primary view.

Split View



ApolloOne has a magnifier that can quickly zoom in to a region of interest. It is available when the image is Zoom to Fit the
window. It is unavailable when image is zoomed in, zoomed out (scaled down). It is also unavailable when a video file is
displayed or in Fluid Swipe mode.

Simply click on the image in the main window to activate the magnifier. There is a delay equivalent to the mouse double click
time interval before the magnifier will popup. The magnifier window shows the content of the image magnified at 100%. You
can drag the mouse around with the image and the magnifier will move and magnify the region under the mouse pointer.

If you have a smaller image that is shown in its entirety in the window, the Magnifier wil magnify the image by 200%. The
Magnifier does not activate if this image is set to Scaled Up to Fit the window.

If you hold down the command key when using the Magnifier, the magnification will be further increased by 200%.

If you double click instead of click and hold, you can still switch to Contact Sheet mode or active the 100% zoom under the
mouse pointer.

You can change the style of the Magnifier or display a crosshair in the middle of the Magnifier. Please see "Preferences... >
Advanced" setup for these settings.

If you have an Apple TrackPad, you can click and hold, and by applying higher pressure, the mangifier will zoom the content
under the mouse pointer at 200% magnification.

You can adjust the TrackPad pressure threshold for switching to 200% magnification.

Please see TrackPadPressureThresholdFor2xMagnification under Special User Defaults for details.

NOTE: In order for magnifier to register higher click pressure for 200% magnification, you need to have Force Click and
haptic feedback setting turned on under System Preferences > TrackPad

Magnifier



ApolloOne has two full screen modes.

To view an image or video full screen without the Folder Browser or Inspector sidebar panels, press the shortcut key enter or
select the menu item under "View > Full Screen".

If you want to have the sidebars visible, press the shortcut key ^⌘F or select the menu item under "View > App Full Screen".

When you set slideshow to start in Full Screen, it will always use the first full screen mode without the sidebar panels.

Full Screen Modes



In addition to having thumbnails displayed in a filmstrip, you can also display them in a grid by switching to Contact Sheet
mode.

Select "Contact Sheet" from the View menu or press the shortcut key C to toggle from photo viewing mode to Contact Sheet
mode. You can also click the "Contact Sheet" button on the Toolbar to toggle in and out of Contact Sheet mode.

You can also double click the main window to switch from image viewing mode to Contact Sheet mode. This is configured
under the Advanced page in Preferences. Simply enable the setting "Switch to Contact Sheet by double clicking on the main
window".

You can quickly preview an image by pressing the spacebar. A popup window will show you a preview image on the selected
thumbnail.

When the Contact Sheet is displayed, you can select multiple files by holding down the Command key or Shift key and clicking
on the thumbnails you want to select. You can also select multiple files by dragging a rectangle while holding down the mouse
click. Thumbnails under the selection rectangle will be selected. You can hold down the Command key when making the
selection rectangle for selecting multiple sets of files.

If you have enabled double click to toggle between image viewing mode and Contact Sheet mode, you can enable the Contact
Sheet selections filter. Simply select the thumbnails you want to view in a list, then double click on any one of the selected
thumbnails. You will be taken back to image viewing mode, but the viewing list only contains the thumbnails (files) you have
selected in Contact Sheet mode. To end this filter mode, just select "Tools > Filter > Off" or double click on the image to get
back into Contact Sheet mode.

Certain operations can be performed when multiple files are selected. These operations are:

Drag-and-drop to external apps, such as Finder, WhatsApp, etc.
Drag-and-drop selected files to a folder in the Folder Browser within ApolloOne. Holding down the Command (alt) key will
change Move to Copy.
Move to Trash
Move only RAW File to Trash
Move only JPEG File to Trash
Move Voice Memo to Trash
Change Finder color tag
Change XMP Rating tag1

Write GPS coordinates data1

Delete GPS coordinates data1

Rotate images1

Edit With2

Edit RAW With2

Edit Video With2

Show in Finder2

File > Share
Edit > Copy
All functions under the EXIF Toolbox

These operations are performed in the background, so you can continue to browse your photos. If you wish to stop a multi-file
operation when it is running, simply press the esc key.

1. These operations can take considerable amount of time to perform.
2. These operations can be selected from the main menu and the context menu.

Contact Sheet



A folder browser is integrated in ApolloOne. You can open the Browser panel by clicking "Tools > Show Browser" from the
menu. You can also open or close the Browser by pressing the ⌘N hotkey or by clicking the  button on the Toolbar or on the
lower right hand corner of the main window if the Toolbar is hidden.

The Browser can be shown in Sidebar or Floating (within the app window) mode. You can select the desired mode under
"Tools > Browser Mode >". When you select Floating mode, the Browser will fade in when the mouse pointer has entered the
floating area of the Browser panel.

You can change the keyboard focus to the Folder Browser from the main window by pressing the Tab key.

ApolloOne is smart to remember the last state of the Browser.

To load the contents of the subfolder in the Browser, simply navigate to the subfolder and single click to load the contents.
You can check the "Include Subfolders" setting to include all subfolders from the folder scan.

If you hold down the Shift key and click on a subfolder to select a range of subfolders, or hold down the Command key to
select multiple subfolders. You can also use mouse drag to select a range of subfolders. The contents of the selected
subfolders will be loaded for display.

ApolloOne remembers the subfolders you have opened and which subfolder you have selected from the last application run.
Folder browser defaults to your Pictures folder on initial application start. If you wish to browse other folder locations or the
entire hard drive, you will need to add other folders to the Places. See Configure Places in the help section.

NOTE: To collapse a folder including all the subfolders below it, Option-click the disclosure triangle.

Folder Browser



If one of the Places is set to the Macintosh HD, and you wish to browse the folders in a different partition or external disk
volume, you will need to navigate to the "Volumes" folder from the root folder (ie: Macintosh HD in most installations).

A context menu is available for the Browser. Simply right click or control-click on the mouse to activate. You can change the
font size, collapse the selected folder and all subfolders underneath it (if you have opened a deeply nested subfolder
structure), include subfolders for scanning, refresh the folder tree and more.

The right click action is context sensitive, meaning it will work on the item you right clicked on. You can create a new folder
under the folder you right clicked, or delete a folder you right clicked. Please note that ApolloOne will not allow you to delete
the folder you are currently viewing.

You can move a file selection into a new folder. Go to Contact Sheet mode, select the thumbnails of the files you want to
move. Right click on the Browser at the folder entry where you want the new folder to be created. Select "New Folder with
Selections (n items)". ApolloOne will prompt you for the name of the subfolder when you want to move the selected files into.
Type the folder name and click the OK button.

There is a Duplicate Folder function and it requires the installation of the User Script, please look under the Enable Trash
Putback help page. It asks Finder to duplicate a folder in the most efficient manner.

You can rename the folder with the "Rename..." function. The selected folder will become editable. Type in a new folder name
and press the enter key to rename.

Keyboard short-cut keys are also supported in the folder browser. These are only available if "Load folder contents with a
single mouse click" in "Preferences... > Advanced" is turned off.

← Collapse the selected folder (does not collapse subfolders underneath the selected folder)
→ Expand the selected folder



↑ Move up
↓ Move down

enter Open and scan the contents of the folder

Folder Monitor
ApolloOne monitors folder changes for the current selected place. When you add, rename, or delete a folder using Finder,
ApolloOne will refresh the folder tree automatically. The only exception is when you create a folder alias using Finder. In this
case, you will need to manually refresh the folder Browser by bringing up the Browser's context menu, and select "Refresh".

Aliases and Symbolic links
The Browser is capable of displaying and accessing folder Aliases you created in Finder or Symbolic links created using the ln
command via the Terminal. This feature requires In-App purchase.

Such folder will be shown with an alias badge on the lower left hand corner of the folder icon.

Please note that in order for ApolloOne to access the contents of such folder, the actual folder location of the alias or symbolic
link must be located under the folder you have set for the Library location. The same restriction applies if the alias points to a
network folder. This limitation is imposed because of the Apple Sandboxing requirement for App Store applications.

If you wish to remove such restrictions, one of the folders in Places must be set to the root folder (ie: Macintosh HD).



ApolloOne has a very informative Inspector panel.

You can open the Inspector panel by clicking "Tools > Show Inspector" from the menu. You can also open or close the
Inspector panel by pressing the ⌘I hotkey or by clicking the  button on the Toolbar or on the lower right hand corner of the
main window if the Toolbar is hidden.

The Inspector can be shown in Sidebar, Floating (within the app window), or detached (separate window) mode. You can
select the desired mode under "Tools > Inspector Mode >". When you select Floating mode, the Inspector will fade in when
the mouse pointer has entered the floating area of the Inspector panel.

ApolloOne is smart to remember the last state of the Inspector panel. When you launch ApolloOne, it will open the Inspector
panel if it was last opened, and it also remembers which info page you were last looking at. If you were previously looking at
the Map Info page, it will open the Inspector panel showing you the Map Info page. It also remembers the size of the window
for the particular page in detached mode.

The Inspector panel shows you detailed camera shooting info from a camera JPEG or camera RAW or video file. On supported
cameras, the Detailed Info page will even show you the camera's internal serial number, shutter count, and other camera
specific information.

ApolloOne has built-in support for over 6000 digital cameras, and it can perform 35mm focal length conversion for these
cameras.

Inspector Panel



You can also turn on the Histogram for the image or video you are currently viewing. Two types of Histograms are available:



Colors and Luminosity. The Histogram setting is remembered by ApolloOne when the app is restarted.

A RGB color patch is available along with the histogram. It shows you the RGB values of the pixel under the mouse pointer
when the mouse pointer is moving within the image.

ApolloOne can retrieve comphresive EXIF, IPTC, MakerNotes, Photoshop and XMP infomation on the Detailed Info page. In
addition, you can search / filter the result by typing text in the search field. Both the "Key" and "Value" fields are searchable.

Favorite tags

You can add tags to your Favorite list by right clicking with the mouse to bring up the Context menu, and then select "Add to
Favorite". You can select multiple tags and add them all at once.



Once you have added all your favorite tags, you can select the menu "Show Favorite" or click the Favorite button (the button
with the heart icon) and display only tags in your favorite list.

When the favorite list is displayed, you can bring up the Context menu, and you can remove any of the tags from favorite or
remove all of them from the favorite list.



On the Detailed Info page, you get a comprehensive listing of EXIF metadata embedded in the image file. Many of these tags
are editable. Just double click to enable editing of the field.

Please see the help page on Editing Metadata for more info.

Adding new IPTC / XMP tags

You can add IPTC and XMP tags that are not present in the image. Right click on the Detail Info page with the mouse to bring
up the Context menu, and then select "Add IPTC / XMP Tags.." A utility panel will popup so that you can select either IPTC or
XMP group, and then select the tag name from the group to add to the image. Type in a value you want for the tag or select
from a list of possible values and click the Add button. If the tag already exists, it will modify the content of the tag instead.
Adding a tag to a RAW file will simply add the tag to the .xmp sidecar file.

There are currently 110 writable IPTC tags and 2309 writable XMP tags.



Searching tags

You can also perform searching on a specific metadata tag. Right click with the mouse to select the metadata tag you want to
search for. When the context menu is up, select "Search...". You will be prompted to enter a search string. Regular Expression
is supported by checking the option Use Regular Expression (RegEx). Click OK to start searching for all files in the file list
for the search string you specified.

To remove this search filter, either select "Tools > Filter > Tune off all Filters" or right mouse click to bring up the context



menu in the Inspector and select "Remove Search Filter".

File filters

You can quickly filter files using the File Filter panel. Just select a combination of the Finder tags and rating tags, the files will
be filtered out for you.

The Keywords Filter shows all the unique keywords that were found after scanning the current file list (browsing session). You
can click on any of the keywords and the files containing the keywords will be filtered out for you.

Please note that the filters operate in an OR operation. That means, if you select the red and green tags, all files containing
the red tag or green tag will be filtered out for you. Similarily for the Keywords Filter.

Editing Spotlight metadata

You can also edit the metadata that ApolloOne sends to Spotlight for indexing. The Keywords field will be indexed by Spotlight
and you can search for images based on the keywords. The Comments field is identical to the Comments: field when you open
the property panel from Finder via "Get Info" by right clicking on the file.



NOTE: In order to edit the Finder Comments field, the ApolloOne.scpt file needs to be installed. This file can be downloaded
from our website. This is a requirement by the App Store. Please refer to "Enable trash put back" for script installation.

https://www.apollooneapp.com/download-apolloone-user-script


ApolloOne has a Toolbar item which contains your Browsing History. It is shown in the upper left handside of the Toolbar by
default. Any new folder you clicked in the Folder Browser will be placed into the Browsing History.

When you select another history item in Browsing History, the current image position is saved and you will be switched to the
folder in the history list, with the same image where you have left off last time.

If Split View is active, both images will be saved and restored when you switch Browsing History.

You can clear the history by selecting the "Clear History" menu item at the bottom of the history list.

Browsing History



Recording slideshow to a video file
ApolloOne has the ability to use the macOS screen recording function to record the slideshow and save it to a H.264 video
file1. This feature is only available to Pro Edition users.

Here are the steps for recording slideshow to a video file:

1. Under the "Tools" menu, activate the recording function by selecting "Record Slideshow to Video File".
2. You will get a System Security prompt asking you for the permission to use the screen recording function.
3. Open "System Preferences", under "Security and Privacy > Screen Recording", enable ApolloOne to use the Screen

Recording function.
4. You have the option to record the slideshow in Full Screen or in a window. To reduce the size of the video file, you should

start the slideshow in a window. The recommended window size is 960x640 points or less. On the Retina Display,
960x640 points translates to 1920x1280 pixels video output. If you want the video to fit into a 1080p display vertically,
the window size you want is 960x540.

5. To set the window size, you can go to "Preferences... > Startup & Delete"page and set the "Initial window size (width x
height)" to the size you want. Then all you need is to press the shortcut key I to set the window to the desired initial size.

6. Make sure the "Switch to full screen" setting is turned off under "Preferences... > Slideshow" if you want to record the
content of the window.

7. Once this is all setup, start the slideshow. You will get another System Security prompt asking you for the permission to
use the Microphone. Click OK to grant the permission.

8. Once Microphone permission is granted, you will get a File Save dialog box, asking you for the location and file name of
where you want to save the video file. After you have specified the file name and location, you will get another dialog box
giving you some tips on how to record the slideshow properly. Follow the instructions and click OK.

9. ApolloOne will record the content of the image display window once slideshow starts. The slideshow will end once
recording is complete. The "Loop slideshow playback" setting is ignored when you are in slideshow recording mode.

10. While the slideshow recording is in progress, please do not move the mouse pointer or move the ApolloOne application
window. Doing so will cause the mouse pointer to be captured during the screen recording, or incorrect content being
recorded if the application window is moved. You should also enable Do No Disturb function in macOS, so that you do
not get any unexpected popups or sounds from system notifications.

11. The default audio capture is your Mac's built-in microphone. You can speak to describe the photos during slideshow screen
recording session.

How to record iTunes music playback during slideshow
ApolloOne has the ability to configure background music playback using an iTunes playlist. Apple limit the screen recording
function to record sound from the microphone only.

This is due to Copyrights and Privacy concerns. However, it is possible to perform screen recording together with iTunes music
playback. This will require installing a 3rd party Audio Loopback Device driver.

The recommended Audio Loopback Device driver is BlackHole2. BlackHole is an open source virtual audio device driver that is
free to use. You can download it here.

BlackHole offers multi-channel audio device loopback drivers, but the one you need for this purpose is the 2-channel version.
Download BlackHole 2-ch and install the driver on your Mac. BlackHole driver works for both Intel and Apple Silicon Macs.

Once the BlackHole loopback/virtual audio device driver is installed, you will see an addition Output device under "System
Preferences > Sound".

Then go to ApolloOne's "Preferences... > Slideshow" setup page. Select BlackHole 2ch under the "Select audio recording
device:" setting.

You can also select a different recording frame rate. If you are recording from a window, you should be able to select 60 fps
recording speed. This will give you smooth slideshow transitions in the recording. If you are recording full screen, 60 fps is not
possible especially if your display is a 5K or 6K display unit.

You can now start the slideshow recording using the BlackHole audio loopback driver. The BlackHole driver does not output
sound to your speakers, so you will not hear the iTunes music playback during the recording of the slideshow. Be rest assured

Recording Slideshow

https://existential.audio/blackhole/?pk_campaign=github&pk_kwd=readme


that the music is being captured to the video file.

How to monitor sound with the BlackHole Audio Loopback driver

If you you want to monitor the iTunes music being recorded, you will need to configure a Multi-Output Device using the
Audio MIDI Setup app in the Utilities folder. Please see the instruction here on how to setup a Multi-Ouput Device.

Remember to select Multi-Output Device in the Slideshow setup in ApolloOne. Then select Sound Input to use the
BackHole 2ch device under "System Preferences > Sound".

In case you have a MMAudio Device in the Sound setup page under System Preferences

An audio loopback driver by the name of MMAudio Device could already be installed in your Mac if you have installed certain
3rd audio capture applications.

In this case, you simply select the MMAudio Device in ApolloOne Slideshow setup.

MMAudio Device does offer sound monitoring, so no additional Multi-Output Device setup is necessary.

1. The audio portion of the video is encoded in MPEG4 AAC (2-ch 44.1K sampling rate). This is a limitation of Apple's screen
recording function.

2. Disclaimer: Anogeissus Limited is not affiliated with the author of BlackHole. Please use the BlackHole audio loopback driver
at your own risk.

https://github.com/ExistentialAudio/BlackHole/wiki/Multi-Output-Device


ApolloOne can use the current displayed photo and set it as the Desktop Wallpaper. When it encounters a video file, it will
capture a video frame from the video and use that as the wallpaper. The captured video frame is placed in your
"Pictures/com.anogeissus.ApolloOne" folder as a JPEG image.

You can capture the video frame while the video is playing. You can also seek and pause the video at a certain time location
and capture a particular video frame there. The JPEG capture is frame accurate.

Desktop Wallpaper



ApolloOne supports Fluid Swipe viewing mode that is similar to the photo viewing experience on the iPhone or iPad.

Fluid Swipe mode is only available if you have a Trackpad (including the built-in Trackpad on a MacBook) or a Magic Mouse.

To enable Fluid Swipe mode, simply select "Start Fluid Swipe Mode" from the View menu or press the shortcut key ⌘S

To exit Fluid Swipe mode, simply select "Stop Fluid Swipe Mode" from the View menu or press the shortcut key ⌘S

You can also enable Fluid Swipe mode on application start. Open "Preferences... > Startup & Delete", and check the "Fluid
Swipe on startup" setting.

Fluid Swipe Mode



ApolloOne remembers the last file you viewed when you close the app. After you restart ApolloOne, you can quickly reopen
the last file you viewed simply by pressing the ⌘R shortcut key.

This will rescan the last folder in which the browsing was started with. The Include options will be applied during the folder
scan.

If you have multiple folders selected in the last session, all these folders will be reopened as well.

Reopen last file on startup
You can tell ApolloOne to automatically reopen this last file on application start. In "Preferences... > Startup & Delete", turn
on the "Reopen last file on startup" setting.

Reopen the Last Viewed File



You can search for files in your collection of images and videos by using the Search field in the Toolbar. You can click the drop
down button on the left and select what you want to search for.

The default search criteria is by File Name. You can search by Folder Name or by Metadata. Metadata only include the fields
that are available in the Edit Metadata dialog box. Fields such as Keywords, Title, Description and Comment, etc. can be
searched when you select Metadata Search.

When you perform search using Metadata, there are addition search options available.

If you separate words by commas (,), each word will be treated as a keyword and any file's metadata containing any of the
keywords will be matched.

If you separate words by a plus sign (+), all keywords have to be present in the file's metadata in order for a successful
match.

NOTE: The spinning wheel located in Places indicates background processing on metadata. You can do a partial match of
metadata if the spinning wheel is shown. When the spinning wheel disappears, all the metadata have been collected, and you
should be able to search for keywords quickly in the search field.

Files Searching



ApolloOne is capable of using the Smart Folders created by Finder.

Creating Smart Folders
This example assumes you have set the Metadata Source to Use macOS Extended Attributes (default) or Combine both
settings under "Preferences... > Metadata".

Right click on the Finder icon in the Dock, and select New Smart Folder

Finder will be opened for you to type in a search criterion. For example, type the word red and wait a few seconds. Finder will
show the word red plus the red tag as the possible criteria.

Select the red tag. This will bring up all files marked with a red tag using ApolloOne or Finder. You can further refine the
results by adding Kind is Image so that only image files are in the result set.

Using Smart Folders



You can click the [+] button to add more criteria or click the [Save] button to save the Smart Folder. When you are prompted
to the location for saving the Smart Folder, you can choose the default, which is ~/Library/Saved Searches (~ means the
folder under your login user name). Alternatively, you can save it to a folder of your choice, in which you destinated it as
storage of Smart Folders for ApolloOne. We do recommend using the latter approach to avoid mixing smart folders of images
with smart folders of other non-image items.

Adding Smart Folders to Places
Open ApolloOne, and open the Folder Browser by either pressing the shortcut key command-N or select Show Browser
from the Tools menu.
In the Places section of the Folder Browser, click the [+] button for adding a new folder to Places.
Select the Smart Folder storage location you used for saving your smart folders.
Or you can add the folder ~/Library/Saved Searches to Places.
Now Click on the location in Places where you saved the smart folders, and click on any of the smart folders below the
Places section and start browsing the images from your smart folder.

NOTE: When opening a Smart Folder, ApolloOne will use a 5 seconds watchdog timer to prevent application from hanging with
corrupted smart folder or criteria design in the smart folder that is taking too long to open.



ApolloOne has a convenient popup context menu for quick access to frequently used functions:

You can access the popup context menu by Control mouse click or right mouse click.

The Sort and Filter menus may not be immediately available when you are loading a folder with large amount of image files. A
background thread is gathering the image files properties for sorting and filtering. Once this background thread is complete,
the Sort and Filter menus will be available. In most cases, the menus will be available in a few seconds.

Of special interest is the "Open Camera RAW With" menu item. When ApolloOne detects the existence of a corresponding
camera RAW file while viewing the JPEG file, this menu item will become available. You can send the camera RAW file to an
external editor for editing.

Popup Context Menu



There are a number of ways you can copy or move files between folders.

Please note that the location of the RAW files copied or moved depends on the user preference "Additional subfolder name to
search for RAW files:". Please see the preference setting here for more detail.

Use Drag-and-drop:
When you are in image viewing mode, you can drag from the main window and drop the image into another location.
When you are in Contact Sheet mode, you can select multiple thumbnails (files) and then drag them out and drop them to
another location.
This location can be your Desktop or a folder in Finder. When dragging to the Desktop or a folder in Finder, the file will be
copied. You cannot move the files to the Desktop or Finder using drag-and-drop from ApolloOne.
If you drop the file(s) into a folder in the Folder Browser, you can select copy or move. The default action is to move the
file(s) to another folder. If you hold down the alt (option) key before you drop, the drag-and-drop operation will change to
copy. That is, the files will be copied to the new location instead of being moved to the new location.
A confirmation dialog will appear if you drop files into a folder in the Folder Browser. The confirmation dialog gives you
three options: "Include Camera RAW File", "Overwrite Existing Files" and "Rename Duplicate Files". Select the options you
want and click the Copy or Move button. The option choices will be remembered once you have executed a copy or move
action.
"Rename Duplicate Files" will override the setting of "Overwrite Existing Files". If the files you are copying or moving to
the destination folder exist, the incoming files will be renamed by appending "-n" (where n is an integer starting from the
value of 1). This allows copying or moving of files without overwriting existing ones with the same names.
You can suppress the display of the confirmation dialog with a setting in Preferences. Uncheck "Preferences... > Advanced
> Show confirmation dialog when moving and copying files".
When the confirmation dialog is suppressed, ApolloOne will assume the options you have selected in the last copy or move
action.

Use Copy To or Move To shortcut submenus:
The "Copy To" and "Move To" shortcut submenus are located under the File menu and the Context menu (control mouse
click or right mouse click on the image display window).
Open the submenu from either the "Copy To" or "Move To" menu item.
Click the "Select Folder..." menu item to select the destination folder to copy or move the file to.
You may receive a confirmation dialog depending on the setting in Preferences.
Once the copy or move action is performed, the destination folder will be listed under the "Copy To" or "Move To"
submenus.
To repeat copying or moving another file to the same destination folder, you can now perform the action with a shortcut
key. Press alt-F1 for moving and ⌘F1 for copying to the same destination folder.
As you select more destination folders via "Copy To" and "Move To" submenus, the destination folders will be added to the
submenus so you can access them via alt-function and ⌘-function keys.
ApolloOne will create shortcut keys up to F19 (F13 to F19 function keys can be found on Mac keyboard with numeric pad).
If you add more destination folders beyond 19 folders, no shortcut key will be assigned to these destination folders.
Click "Clear Menu" to clear the list of shortcut destination folders if you wish to start a new list of shortcut destination
folders.

Use Tools > File > Copy... / Move... submenus:
Typically, you use this copy or move function after you have applied a file filter. For example, you want to move all the
files tagged with a 5-star rating.
Select the filters desired from the "Tools > Filter" menu or click one of the filter options under the Inspector Filter panel.
A dialog box is presented so you can select the destination folder. ApolloOne will present you with the last destination
folder used for copying or moving files.
Select the options desired: "Overwrite Existing Files" and "Include Camera RAW Files".
Click the "Copy" or "Move" button.
Use this function if you need to copy or move a large amount of files in the background.

Copying and Moving Files



ApolloOne supports many types of drag-and-drop operations.

For viewing and downloading images from a website:
You can drag-and-drop multiple files and folders to the ApolloOne app icon. ApolloOne will be launched immediately with the
list of dropped items.

You can also drag-and-drop multiple files and folders into the main window.

You can also drag-and-drop an image URL from a web browser into the main window (in image display mode, not Contact
Sheet mode). ApolloOne will start downloading the image in the background into the folder that is currently being viewed.
Once the download has completed, the image will be displayed immediately.

If you wish to drag-and-drop image URLs into a new folder, you will need to first activate Auto Advance mode, then select the
new folder from the Folder Browser.

You can drag-and-drop multiple image URLs into the main window, they will be downloaded simultaneously in the background.

Sometimes an image displayed in a web page is actually an HTML link. In this case, no image will be downloaded.

For copying to external applications:
You can drag out the image file (URL) from the image display window into another application, such as a document or photo
editing application. The image file will be sent to the application. You can also drag out a video as a file into another
application.

In photo viewing mode, if the image content is not zoomed in, you can simply drag the mouse once the magnifier is outside
the image display area, it will change to a thumbnail, allowing you to drop the file into an external application such as Finder.

In the image is zoomed in, you can drag out the image file by holding down the ⌥ key before dragging the image out of the
image display area.

In Contact Sheet mode, select the thumbnails you want to drag out, and drag on one of the selected thumbnails.

You can also drag out just a portion of a zoomed image. Hold down the fn key and perform the mouse drag. When you drag
out the content of a zoomed image, only the portion of the image displayed in the window is being copied to the destination.
This depends on whether the application at the destination would accept the content of this drop. Usually, only a word
processing application or photo editor will accept this kind of drop.

There is an image conversion function for drag-and-drop. For example, if you try to drag a HIF or RAW file into WhatsApp, it
may not understand these file formats as images. In this case, you can have ApolloOne convert them to JPEG before dropping
the file into WhatsApp. Hold down the Shift key before dragging the image out of the image display area.

For moving and copying to another folder with ApolloOne:
When you are in Contact Sheet mode, you can select multiple thumbnails (files) and then drag them out and drop them to
another location. This location can be your Desktop or a folder in Finder. You can even drag the files from the Contact Sheet
(or Finder) and drop them into a folder in the Folder Browser. If you hold down the alt (option) key before you drop, the drag-
and-drop operation will change to copy instead of move. That is, the files will be copied to the new location instead of being
moved to the new location.

You can only darg-and-drop to the Folder Browser if it is set to Sidebar mode. You cannnot use Floating mode for dragging
and dropping files into the Folder Browser.

When dropping files into the Folder Browser, a dialog box will pop up and give you the options to "Include Camera RAW File"
and "Overwrite Existing Files". Select the options desired before clicking the Move or Copy button.

You can disable the confirmation dialog box by unchecking "Show confirmation dialog when moving or copying files" under
"Preferences... > Advanced".

NOTE: You cannot drag-and-drop files to a Smart Folder (Saved Search folder).

Drag-and-drop





File tagging uses macOS built-in Tags, which is the same Tags used by Finder. The Finder Tags are stored in the file's
extended attributes metadata fields.

You can tag a file when you are viewing normally or during the slideshow.

To help speed up the file tagging process, you can press shortcut key A or caps lock key to turn on Auto Advance mode.

There are 7 colors available for tagging, these are the same color tags available in Finder. You can tag the image with a
combination of color tags.

You can toggle the color tags on or off by clicking the corresponding color tag from the Tools menu or from the context menu.
You can also use shortcut keys alt-1 to alt-7 to turn on or turn off the color tags quickly. Press alt-0 if you want to turn off
all the color tags at once. alt-1 corresponds to the red tag, and alt-2 to the orange tag, etc.

Once the files are tagged, you can perform filtering and file operations on the tagged files.

Select "Tools > Filter" to select one of the file filters.

Select "Tools > File" to select a file operation.

You can copy, move or trash the color tagged files.

You can also remove the color tags from all files you have tagged.

Select all the color tagged files in Contact Sheet mode, then select tag None or press the shortcut key alt-0 to remove all
color tags.

In most situations, you will want to turn on the filter first before performing any file operation.

Using Finder Tag Filter in the Inspector
Alternatively, you can use the Finder Tag Filter in the Inspector.

Open the Inspector by selecting "Tools > Show Inspector" or press ⌘I.

Click open the Finder tag Filter.

Select the color tags you want to filter. Files containing one of the selected tags will be filtered.

You can combine this with the Rating Filter to refine your result. A logical OR is performed when you have enabled both filters.

You can refine the filter by combining the filter menu items under "Tools > Filter". A logical AND is performed with the filters
results from the Inspector Filter panel.

Note: When you tag a file, the corresponding RAW file is tagged only when Display Mode is set to Combine JPEG
+ RAW.

File Tagging



You can rate file via star rating. Star rating is stored in the XMP metadata Rating field. This metadata field is compatible with a
variety of third party applications.

You can rate a file when you are viewing normally or during the slideshow.

You can rate a file from one star to five stars.

You can also use shortcut keys command-1 (1 star) to command-5 (5 stars) to rate the file quickly. Press command-0 (or
command-`) if you want to mark the file unrated. Press command-X if you want to rate it as Rejected.

To help speed up the file rating process, you can press shortcut key A or caps lock key to turn on Auto Advance mode. When
Auto Advance mode is activated, you can change the Star Rating with or without holding down the command key. For
example, you can just press 5 to give a 5-star rating to a file.

ApolloOne is compatible with the XML file standard when you rate a video file or camera RAW file. When you rate these types
of files, a separate XMP sidecar file is created. However, if an XMP sidecar file already exists, it will simply update the content
of the XMP sidecar file. Your video and camera RAW files will be left untouched.

The exception is for DNG camera RAW files. XMP metadata will always be written directly into the DNG file.

Once the files are rated, you can perform filtering and file operations on the rated files.

Select "Tools > Filter" to select one of the file filters.

Select "Tools > File" to select a file operation.

You can copy, move or trash the rated files.

You can also remove the ratings (unrate) from the files you have rated.

Select "Tools > File > Remove Ratings..." to remove all tags from the current file list.

In most situations, you will want to turn on the rating filter first before performing any file operation.

Using Rating Filter in the Inspector
Alternatively, you can use the Rating Filter in the Inspector.

Open the Inspector by selecting "Tools > Show Inspector" or press ⌘I.

Click open the Rating Filter.

Select the ratings you want to filter. Files containing one of the selected ratings will be filtered.

You can combine this with the Finder Tag Filter to refine your result. A logical OR is performed when you have enabled both
filters.

You can refine the filter by combining the filter menu items under "Tools > Filter". A logical AND is performed with the filters
results from the Inspector Filter panel.

Note: When you rate a file rating, the corresponding camera RAW file is not rated. To rate camera RAW files, you need to turn
on "Include Camera RAW Files" and run the "Rescan Current Folder" under the Tools menu. The rating needs to be performed
directly on the camera RAW file itself.

Search for files with Rating in Finder
You can also search for files with a certain rating in Finder.

Typed in a search criteria in Finder, then click the [+] button next to the "Save" button on the right to bring up the search
criteria bar. In the popup button that shows "Name", select "Other...".

Scroll down the list and put a check mark next to Rating then click OK.

Star Rating



Now select Rating as the search criteria, and select the operator for comparison (e.g. equals), and then type a rating value
(e.g. 5). All files with Rating equals to 5 will be displayed by Finder.



ApolloOne has an Auto Advance mode that helps you rate / cull image files quickly. In addition, you can use it with camera
tethering software/plug-ins such as Fujifilm X-Acquire to display newly captured image by the camera in tethering mode.

You can start Auto Advance mode by pressing the shortcut key A or by pressing the caps lock key.

For example, when you change the star rating by pressing the shortcut keys 1 (1 star) to 5 (5 stars), ApolloOne will
automatically advance to the next file. Please note that in Auto Advance mode, shortcut keys for star rating will change from
command-1 to 1, etc. to help speed up the rating process.

Here is a list of operations that will cause ApolloOne to advance to the next file:

Change Finder Tag
Change Star Rating
Move only RAW File to Trash
Write or Delete GPS Data

Once images are tagged/rated, you can activate one of the filters to perform copy, move or trash operation.

Working with Camera Tethering software:
To use the camera tethering feature, you will need a 3rd party software that captures images from the camera in tethering
mode via a USB cable.

Set the camera to tethering mode and connect it to the Mac with a long USB cable (some cameras support connection via
network cable)
Set the camera tethering software's destination folder (such as Fujifilm X-Acquire)
Start ApolloOne
Start Auto Advance mode
Select the tethering software destination folder from the Folder Browser in ApolloOne
Alternatively, you can drag-and-drop the tethering software's destination folder into ApolloOne's main window
Start shooting with the camera

As you start shooting with the camera, the newly captured image will be displayed immediately by ApolloOne. You can change
the Film Strip Mode to Floating if you wish to have a larger image viewing area.

Auto Advance / Camera Tethering



Sorting
When ApolloOne opens a folder or folder tree for images, it also builds a list of image properties for sorting and filtering.

A progress indicator appears in Places when it is gathering image properties in the background. Once this background process
is complete, sorting and filtering menus will become available.

Just select any menu item in the Sort menu to perform the sorting of images. Thumbnails will be rearranged in the film strip
when sorting is complete.

You can also define your own custom sorting criteria. Select "Sort > Define Custom..." You can select the first sort key, the
second sort key, and whether to sort in ascending or descending order for each sort key. Once the custom sort keys are
defined, you can select "Sort > Custom" to perform your custom sorting criteria.

ApolloOne remembers the sorting selection you have made. All images will be sorted automatically on application start.
However, automatic sorting is only performed once all the image properties have been built.

Sorting with User Defined Sequence

You can arrange (sort) the files with user defined file sequence. To do this, go into Contact Sheet mode, select the thumbnail
or thumbnails and drag-and-drop them to another location. To help you to narrow down to a specific set of files, you can also
select the "Hide Thumbnails" menu item in the Context menu (right mouse click or control-mouse click in the image or
thumbnails display area to bring up the Context menu). Thumbnails will be hidden for the session but they are not deleted.
Once you are satisified with the thumbnail arrangement, select "Sort > User Defined Sequence > Save..." menu item. A file
save dialog will be presented for saving the file sequence property list file (.plist). When saving User Defined Sequence
property list file, you do not need to enter .plist in the file name.

The sequence .plist file you saved will be used as default when sort order is set to "User Defined Sequence" during app start
or when you switch to this folder in the Folder Browser. You can have multiple .plist files for different file ordering if desired.
You can load a different .plist sequence file by selecting "Sort > User Defined Sequence > Load..." menu item.

If you select or save a property list (.plist) file via the "User Defined Sequence" Load... or Save... menu items, this .plist file
will be remembered when you come back to this folder the next time if sort is set to User Defined Sequence.

To show all files, you need to select Sort other than User Defined Sequence (such as File Name), and press the shortcut key R
to rescan the files in the current folder or by selecting "View > Display Mode > Rescan Current Folder Selection".

Keep Folder Sort Settings

You can save the sort settings (sort by File Name, sort by File Size, Sort by Custom, etc.) on a per folder basis, simply by
turning on the "Keep Folder Sort Settings". When you switch folders, the previous sort settings you set for the folder will be
loaded, and files rearranged according to the previous sort settings.

Filtering
You can filter files using the Filter panel in the Inspector. The filters in the Inspector allow simple filtering of Finder color tags
(or XMP color labels), rating stars and keywords embedded in the files.

Open the Inspector by selecting "Tools > Show Inspector" or press ⌘I.

Click open the Color Tag Filter.

Select the color tags you want to filter. Files containing one of the selected tags will be filtered. You can select multiple color
tags and all files matching any of the color tags will be filtered out.

Similarly for the Rating Filter group or the Keywords Filter group. For example, if you select 4-star rating and 5-star ratings,
all files with either 4-star or 5-star rating will be filtered out.

You can combine this with the Rating Filter to refine your result. A logical AND is performed between the filter groups.

To continue with the above example, if you click the Red color tag, and a keyword in the Keywords Filter, then only the files

Sorting and Filtering



matching 4-star or 5-star rating together with a Red tag and with the keyword will be filtered out.

You can refine the filter by combining the filter menu items under "Tools > Filter". The menu item filters are performed with a
logical AND with the filter results from the Inspector Filter panel.

To turn off a filter from the menu, click on the same filter menu item to turn the filter off.

It is often useful to perform the filter first before running a file operation, such as Copy or Move ("Tools > File").

Quick Rating Filter
You can filter files with a certain rating or higher with shortcut keys. Press command+option+number key will filter files with
the same number key and higher ratings. If you want to filter files with 3 or more ratings, press command+option+3 keys.

Advanced Filters
You can filter files using a combination of filters under the Filter menu. The selection of filters under the Filter menu are
logically AND'ed together.

Most filters under the Filter menu are self explanatory, the more advanced filters will be covered below.

Filter within GPS Distance Measurement...

This is a very powerful filter which allows filtering of all photos within a distance you specified from the current photo's GPS
coordinate. The current photo and all filtered photos must have GPS coordinates metadata in order to perform the distance
computation.

This filter works for both Apple Maps and Google Maps.

This filter does not take into the consideration of altitude. GPS coordinate with 0 altitude will work without issue.

You can open the Inspector's Map page, and drag the marker (pin) to a different location on the map, and this filter will use
the coordinate on the marker as the starting point for the distance filter.

If the photo does not have GPS metadata, you can perform a search on a location or simply drop a marker on the map, and
the filter will use the marker's GPS coordinate for the distance filter.

This distance between two GPS coordinates is computed using Vincenty's Formula, which is highly accurate. In reality, the
distance accuracy is limited by the GPS sensor, and in most cases, the resolution is limited to 5 meters. When more accurate
GPS sensors are available, ApolloOne's distance computation engine would be ready to give you more accurate results.

In specifying the filter's distance parameter, you should specify at least 5 meters (16.4 feet) as minimum unless you know the
device capturing the photos uses a higher resolution sensor that can receive the L5 band signal, which is accurate to the
centimeter range.

Filter within GPS Altitude Distance...

This filter allows filtering of all photos within an altitude distance you specified from the current photo. The current photo and
all filtered photos must have GPS coordinates metadata in order to perform the distance computation.

Selections on Contact Sheet

This filter allows filtering of all photos selected in Contact Sheet mode. You can also activate this filter by double clicking on
any of the selected photos in Contact Sheet mode. And double click again on the photo to get back into Contact Sheet mode
with thumbnail selections.

Invert Current Filters

This filter allows inverting the result set of the current active filters.



You can invoke an external editor by using the popup context menu. You can bring up the popup context menu by Control
mouse click or right mouse click on the main window.

If the image is a JPEG / BMP / TIFF / PNG / GIF image file or a video file, you can launch the external editor registered in your
system by selecting it under the "Open With" menu.

If the image is a camera RAW file, you can launch the external editor registered in your system by selecting it under the
"Open Camera RAW With" menu.

You can quickly launch the external editor by using "Edit with", 'Edit Video with" or "Edit RAW with" menu item under the main
Edit menu. This menu changes dynamically depending on whether you are viewing a regular image, a camera RAW file or a
video file. A shortcut key is associated with "Edit with", "Edit Video with" or "Edit RAW with" menu item so you can launch the
external editor quickly by pressing ⌘E.

You can assign a different external editor to "Edit with", "Edit Video with" and "Edit RAW with" menu items.

To select the external editor, simply launch it once from the context menu "Open With" or "Open Camera RAW With", and the
"Edit with", "Edit Video with" or "Edit RAW with" menu choice will be set.

To change the external editor, just launch a different external editor with "Open With" or "Open Camera RAW With" from the
context menu.

Once the external editor has been set, you can also click on "Open With" or "Open Camera RAW With" context menu, and the
external editor will be launched without the need to go into the submenu to select it.

The "Open With" submenu and "Open Camera RAW With" submenu will show the shortcut key ⌘E next to the external
application to indicate which selection is being used by "Edit with", "Edit Video with" or "Edit RAW with" menu items.

Using External Editor



ApolloOne lets you manage your keywords in a simple and effective way.

Keywords are typically used as metadata by giving an image file a single or multiple human readable keyword texts for classification purpose.
You can locate files from your library quickly by filtering files using keywords.

Keywords are supported by ApolloOne in the following ways: Managing the keywords dictionary, keywords filtering, keyword searching, and
instant matching of keywords in the dictionary as you input keyword to your image.

Managing Keywords

You can open the Keywords Manager by using the menu item "User Metadata > Manage Keywords Dictionary...". You can also bring up the
Keywords Manager quickly by pressing the shortcut key command+option+K.

The Keywords Manager lets you to add, edit, delete, and search for keywords in the dictionary. This dictionary provides a set of keywords for
quick keyword entry in the Edit Metadata panel.

Click the [+] button to add a new keyword. If the new keyword is a duplicate, you will hear a beep sound and the keyword will be removed.
Keywords in the dictionary are case-insensitive.

Click the [-] button to delete a keyword. You can select multiple keywords and delete them at once.

You can select an existing keyword, click on the text to modify it.

When you press the enter key, the new or modifiied keyword will be saved.

Press the esc key to close the Keywords Manager.

Adding Keywords to your image

You can enter or edit keywords stored in your image file's metadata by using the "Edit Metadata" panel. It is under the menu "Edit > Edit
Metadata...". You can also use the shortcut key ⌘M to bring up this Edit Metadata panel.

Before editing your metadata, please check to see if you have the Metadata Source configured according to your preference. The Metadata
Source can be set under "Preferences... > Metadata". Please consult the chapter Metadata Setup for more information.

Using the "Edit Metadata" screen, click the Keywords field. As you start typing in keyword, any matching keywords will be shown as a popup
window on the left. You can quickly select the keyword by pressing the corresponding function key on your keyboard or by double clicking the
desired keyword in the popup window and the keyword will be filled in for you.

You can enter multiple keywords using (;) or (,) as keyword separator. The popup window will continue to show for any matching keyword in the
dictionary, even for keyword entered between the keyword separators.

Managing Keywords



You can hide the popup window by pressing the esc key.

You can also bring up the Keywords Manager when the Edit Metadata panel is active by pressing the shortcut key ⌥⌘K.

You can go into Contact Sheet mode, select multiple thumbnails and then press ⌘M to bring up the Edit Metadata panel.

When the keywords field has multiple values from different files, you will see *** multiple values *** displayed in the field. If you do not
change the text in this field, then clicking the Save button will not alter existing values.

If you wish to add a new keyword to multiple files that already have a mixed of different keywords, you need to enter the new keyword with a +
sign in front so that the new keyword will be added to each file.

If you wish to remove an existing keyword from multiple files with a mixed of different keywords, you need to enter the new keyword with a -
sign in front so that this keyword will be removed from each file.

Type over the text *** multiple values *** when adding or removing keywords with the + or - prefix.

Filtering and searching for images with Keywords

Once you have images associated with keywords, you can find them quickly using the File Filters in the Inspector.

When you open a folder (or multiple folders and subfolders), ApolloOne will index all the metadata and present you with a list of unique
keywords found that are associated with the current browsing session. This list is shown under the Keywords Filter.

You can put a checkmark next to a keyword in the Keyword Filter, all the files with metadata containing the keyword will be filtered out for
you. If you put a checkmark in multiple keywords in the Keywords Filter, all files that contain any of the keywords will be filtered out for you.



If you want to specify filter with files containing more than one keyword, you will need to use the Search field in the Toolbar and use a + sign as
keywords separator so that all keywords separated by (+) need to exist in the file's metdata in order to fullfill the search criteria. Please refer to
the chapter File Searching for more information.

You can add the keywords found by the Keywords Filter to your Keywords Dictionary by right clicking with the mouse to bring up the Context
menu, and then select "Add to Keywords Dictionary". You can select multiple keywords and add them all at once.

You can also remove the keywords found by the Keywords Filter by selecting "Remove from Keywords Dictionary" in the Context menu. This
will remove the keyword in the Keywords Dictionary.

You can refresh the keywords in the Keywords Filter if you believe it is out-of-date. This will trigger the metadata scanning process. This
process will look at the modification datetime stamp of the files and compare that to the keyword database to ensure the keywords in the
database are up-to-date for fast keywords searching and filtering.



You can edit the file's metadata (Extended Attributes, EXIF, MakerNotes, IPTC and XMP groups) with ApolloOne using the
Inspector and the Edit Metadata panel.

When you update the metadata, a backup copy of the original file will be saved. This is true when Metadata Source set to "Use
XMP" or "Combine both settings". ApolloOne will append _original to the file extension. For example, DSC_0862.JPG
becomes DSC_0862.JPG_original. If you do not wish to have a backup copy of the original file, you can turn it off by
unchecking the setting under "Preferences... > Advanced > Backup original file before making changes".

The "Edit Metadata" panel provides editiing function for the most commonly used IPTC/XMP metadata. These are: IPTC:By-
line, IPTC:Writer-Editor, IPTC:CopyrightNotice, IPTC:ObjectName, IPTC:Headline, IPTC:Sub-location, IPTC:Keywords
(Spotlight Keywords), IPTC:Caption-Abstract, XMP-dc:Creator, XMP:CaptionWriter, XMP:Rights, XMP-dc:Title, XMP:Headline,
XMP:Location, XMP-dc:Subject, XMP-xmp:Label, XMP:Rating, XMP-dc:Description, XMP:UserComment (Finder Comments),
EXIF:Artist and EXIF:Copyright. Changing of these metadata are only available when the Metadata Source is set to "Use XMP"
or "Combine both settings".

When Metadata Source is set to "Use macOS Extended Attributes", the metadata are stored in the file's Extended Attributes,
instead of IPTC/XMP tags.

Please note that ApolloOne saves the EXIF, IPTC, and XMP metadata directly in the JPEG, HEIC, TIFF and PNG files. For
camera RAW files and video files, the metadata are saved as a sidecar XMP file (i.e. file with the same name but .xmp
extension). Therefore, only XMP metadata can be saved for these file types.

Steps for editing metadata with the Edit Metadata panel
Open the Edit Metadata panel by selecting "User Metadata > Edit Metadata" or press the shortcut key ⌘M.
Make the desired changes and click the Save button. You can also press the shortcut key ⌘S to save the changes.
When Auto Advance mode is turned on, ApolloOne will advance to the next file automatically once you have saved the
metadata.
You can click the Copy button to copy the metadata to an internal buffer. Click the Paste button to paste the buffer to the
metadata fields of another file.
You can go into Contact Sheet mode, select multiple thumbnails and then press ⌘M to bring up the Edit Metadata panel.
When the field has multiple values from different files, you will see *** multiple values *** displayed in the field. If you
do not change the text in this field, then clicking the Save button will not alter existing values.
If you wish to add a new keyword to multiple files that already have a mixed of different keywords, you need to enter the
new keyword with a + sign in front so that the new keyword will be added to each file.
If you wish to remove an existing keyword from multiple files with a mixed of different keywords, you need to enter the
new keyword with a - sign in front so that this keyword will be removed from each file.
Type over the text *** multiple values *** when adding or removing keywords with the + or - prefix.
If you put a + in front of an existing keyword and clicked the Save button, this keyword will be repeated twice in the
keywords tag.
NOTE:
When the Metadata Source is set to "Combine both settings" in Preferences, the Spotlight Keywords and
Finder Comments will also be updated simultaneously.
When the Metadata Source is set to "Use XMP" or "Combine both settings" in Preferences, the XMP:Label will
be updated with a single color tag.
You can use ⌘S to save changes. ⌥⌘C for copying the fields, and ⌥⌘V for pasting the fields.
You can use shortcut keys ⌘1-⌘5 for changing the rating star. Press ⌘0 for clearing the rating, ⌥⌘X for
marking the rating with an X.
You can use shortcut keys⌥⌘1-7 for changing the color labels/tags. Press ⌥⌘0 for clearing the label.

Steps for editing metadata with the Inspector
Open the Inspector by selecting "Tools > Show Inspector" or press the shortcut key ⌘I. Go to the Detailed Info page (click
the second button across the top), where you can see all the metadata.
Expand the metadata group to find the tag you wish to edit.
Double click on the tag.
If it is a text field, it will become editable. Type in the new text. Press the enter key to save. To cancel editing, select
another tag or press the esc key.
If it is a field with pre-defined values, a popup will be presented. The pre-defined values are translated to the user's
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current language locale if available. Click on the popup and select one of the possible selection values. As soon as a new
value is selected, it will be saved to the file. To cancel editing, select another tag or select the key column of the tag.
NOTE:
Updating EXIF metadata directly will not affect the file's extended attributes.

Important notes on editing Metadata
Only the following color tags are compatible with 3rd party applictions using XMP-xmp:Label tag: Red, Yellow, Green, Blue
and Purple.
When editing metadata with the Inspector, not all metadata fields are editable. Some are not editable due to the field's
specification (read-only), and some fields are not enabled by ApolloOne to be editable due to the complication in editing
the field structures.
When you edit the metadata of HEIC files, the changes are saved as XMP group inside the HEIC file. This includes GPS
coordinates data, and metadata displayed in the Inspector's Detailed Info page.



The Camera Metadata menu contains a powerful set of tools for altering camera produced EXIF metadata of an image or video
file.

These functions modify the content of the file. It is recommended you have a backup copy of your files or turn on the file
backup feature of Apollone to safe guard any possibly of file damage.

When processing video files, the processing time can take a long time, especially when ApolloOne is set to make a backup
copy of the video, and the video is multi-Gigabytes in size. In general, it is best to avoid making metadata changes on very
large video files.

When you execute one of the functions in this menu, only the currently displayed image or video is processed. You can
process multiple images and/or videos by going into Contact Sheet mode, select the thumbnails (ie: image files, video files)
and then execute the one of the functions.

Copy EXIF Digitized Date from File
This function copies the EXIF digitized datetime from the selected file into the pasteboard. You can use this to write to multiple
files for setting their digitized date (see Write EXIF Digitized Date below).

Write EXIF Digitized Date
To use this function, switch to Contact Sheet mode, select the files (thumbnails) you want to set the EXIF Digitized Date and it
will write the Digitized Date into the selected files.

Set File Creation Date to EXIF Digitized Date
This function retrieves the EXIF digitized datetime and set the file's creation datetime to this value.

For image files, ApolloOne will try to retrieve a valid digitized datetime in the following order: EXIF:DateTimeOriginal,
EXIF:CreateDate, MakerNotes:DateTimeOriginal and MakerNotes:CreateDate.

For video files, ApolloOne will try to retrieve a valid digitized datetime in the following order: QuickTime:CreationDate,
QuickTime:ContentCreateDate, EXIF:DateTimeOriginal, EXIF:CreateDate, MakerNotes:DateTimeOriginal and
MakerNotes:CreateDate.

Set File Modification Date to EXIF Digitized Date
This function retrieves the EXIF digitized datetime and set the file's modification datetime to this value.

Set EXIF Digitized Date to File Creation Date
This function sets the EXIF digitized datetime to the file's creation datetime.

Set EXIF Digitized/Create Date...
This function sets the EXIF digitized datetime to the datetime specified by the user. The input format is in YYYY-MM-DD
HH:MM:SS (year, month, day, hour, minute, second) format. ApolloOne will automatically fill in the dashes "-" and colons ":"
for you. All you need is to type in the digits to specify the datetime value.

Shift EXIF Digitized/Create Date...
This function shifts the EXIF digitized datetime with the datetime offset value as specified by the user. For example, if you
forgot to set the clock in your digital camera when you traveled to a different timezone, you can correct the digitized datetime
in the EXIF metadata with this tool. If you need to shift by +8 hours, for example, you just fill in 0000-00-00 08:00:00. If you
need to shift by -8 hours instead, click the checkbox Move Datetime Backward to tell ApolloOne to move the date time to
an earlier value. You can even specify something like 0000-14-00 00:00:00 to move forward by 14 months.

Delete GPS Coordinates
This function deletes the GPS coordinates metadata from the file.

Camera Metadata 



Delete Serial Number Metadata
This function deletes serial number metadata from the file. This can be camera serial number, lens serial number and internal
serial number.

Delete Makernotes Metadata
This function deletes the manufacturer specific MakerNotes group from the file.

Delete ICC Profile
This function deletes the ICC Profile from the file. It may cause incorrect color rendering of the image if ICC profile is
removed. 

Delete All Metadata
This function deletes all metdata (EXIF, MakerNotes, XMP, IPTC, etc.) from the file. Some Nikon NEF files do not support all
metadata to be removed.



The User Metadata contains a powerful set of tools for altering user generated metadata of an image or video file.

These tools modify the content of the file, except for RAW files and video files. It is recommended you have a backup copy of
your files or turn on the file backup feature of Apollone to safe guard any possibly of file damage.

When processing RAW files or video files, it will create a .xmp file for storing the metadata. The RAW files or video files
themselves are unmodified.

When you execute one of the functions under this menu, only the currently displayed image or video is processed. You can
process multiple images and/or videos by going into Contact Sheet mode, select the thumbnails (ie: image files, video files)
and then execute the one of the functions.

The template files are stored in the user's default login directory under Documents/ApolloOne/xmp. You can modifiy this
storage location under "Preferences... > Metadata > Change Folder".

Manage Keywords Dictionary...
You can create keywords with this function so that the keywords can be quickly recalled when editing the keywords field in the
Edit Metadata dialog. See Managing Keywords for more details.

Edit Metadata...
This function allows you to manage the file's metadata so that searching, filtering can be used to locate the files. The
metadata can be stored in macOS Extended Attributes or as standard XMP/IPTC tags. Please see Metadata Setup for more
details.

You can learn how to Edit Metadata by clicking this link

Edit Metadata with Template
This function lets you edit the file's metadata by pre-filling the metadata values from a selected template. Select one of the
templates you created previously from the submenu.

You can create, edit or delete the metadata templates by using the templates functions described below.

Create Template...
This function brings up a dialog box that looks almost identical to the Edit Metadata dialog. However, after filling in the fields,
you can save the metadata to a .xmp file as template for later use. Since a standard .xmp file is used, you are only allowed to
use 5 standard Label Colors, even if your Metadata Source is set to use macOS Extended Attributes, which has 7 label colors
(or Finder color tags).

Edit Template
This function lets you edit the .xmp template you created with the previous function. Select the template you want to edit in
the submenu.

Delete Template
This function deletes the template by selecting the one you want to delete in the submenu. If the User Script is installed, it will
use the Finder delete function to move the template file into the Trash or Bin.

Attach without Replacing
This function attaches the metadata in the template to the file. Select the metadata template in the submenu. If the file has
an existing metadata field, such as Title, this function will not overwrite the Title field with the one stored in the template. For
Keywords fields, new keywords will be merged from the template to the file. You can specify the modifier prefix keys (+ or -
sign) in front of the keywords when defining the template, such that keywords can be added to or deleted from the image file.

To attach metadata template to multiple files, go into Contact Sheet mode, select the thumbnails you want to attach the
metadata, then execute this function.

User Metadata



Replace
This function replaces the metadata values of the image file with the ones defined in the template. Template with empty fields
will cause the same field to be deleted from the image file.

Sync XMP Sidecar File to Image...
This function synchronizes the XMP tags from .xmp sidecar file into the image file. Only files other than RAW or video can be
sync'ed.

You can select what not to sync with the option dialog box. If you uncheck the option button for "Sync Creation Date", "Sync
Title, Description, Keywords" or "Sync GPS", then these tags inside the xmp file will not be synchronized with the image. You
also have the option to delete the xmp sidecar file once synchronization is complete. The default behavior is to keep the xmp
sidecar file. The xmp sidecar file may contain image editing information that you may want to keep.

In addition, if your Metadata source is set to "Use macOS Extended Attributes" or "Combine both settings", the Extended
Attributes that correspond to the XMP tags will be synchronized. Only the XMP tags shown in Edit Metadata panel will be
synchronized to the Extended Attributes.

Delete XMP Metadata
This function deletes the XMP metadata from the file.

Delete IPTC Metadata
This function deletes the IPTC metadata from the file.

Delete All Metadata
This function deletes all metdata (XMP, IPTC, etc.) from the file.



ApolloOne has a very powerful GPS address locator function. It can retrieve the actual street address from the GPS
coordinates embedded in the photos or videos.

GPS coordinates are typically attached to photos or videos taken with smartphones or cameras with dedicated GPS sensors.
Some newer mirrorless cameras can also retrieve the GPS coordinates information by communicating with a dedicated app on
the smartphones.

On the iPhone, you can do this by turning on Location Services.

You can import photos or videos on your iPhone using the Preview application. Launch Preview and select "File > Import from
iPhone..." from the menu.

When ApolloOne is first launched, it will ask for access to Location Services. If you have granted it access to Location Services,
it can locate your current whereabout and show it to you on the map.

You can display a map of your current location by selecting the context menu "Show my current location" on the Inspector's
Map Info page. You can turn on or off location access from "System Preferences > Security & Privacy > Privacy > Location
Services" by checking or unchecking ApolloOne from the list of applications under "Enable Location Services".

ApolloOne starts by inspecting the metadata of the file to see if GPS coordinates were recorded. If GPS coordinates are found,
it will perform Reverse Geocoding to locate the actual address from the coordinates. The file can be a JPEG, a camera RAW or
a video file.

Reverse Geocoding is performed via a web service. It is only available if your computer has an Internet connection. If you
have a firewall installed, please allow ApolloOne to access the Internet. There is no limit on how many times you can request
the Reverse Geocoding web service. However, the limitation is that you can only request such service at the rate of one
request per second.

Maps and GPS Address Locator

https://en.wikipedia.org/wiki/Reverse_geocoding


To enable the GPS address locator function, open "Preferences... > Geotagging & Indexing", check the "Find the street
address using GPS data in the image file" setting.

To see the address and the map, open the Inspector panel by clicking "Tools > Show Inspector" from the menu, and click on
the map button. You can also open or close the Inspector panel by pressing the ⌘I hotkey.

Searching



You can perform searching by typing a query in the search field. You can search by natural language whether you are using
the Apple Maps or the interactive Google Maps.

Google Maps
Google Maps is also available besides Apple Maps. Right click on the map, and select "Use Google Maps".

Due to Google Maps API Key licensing restrictions, the default map uses non-interactive Google Maps. You can enable
Interactive Google Maps by specifying an API key. Please look under the section "Interactive Google Maps setup".



You can also view the map in an external browser. Right click on the map and select "Open map in browser". Google maps will
be used when the map is displayed in the browser.



You can enable the Interactive Google Maps that uses Javascripts. The map loads faster, and you can drag the marker to a
new map location, copy it, and use the new marker location to update the file's GPS position data.

Starting from July 1st 2020, Google is granting unlimited maps access for macOS apps, and ApolloOne will
provide its internal access key for Interactive Google Maps. No additional setup is necessary.

How to enable Google Maps
Open the Inspector
Select the "Map Info" page
Right click on the map, and select "Use Google Maps"

Interactive Google Maps Setup





You can edit the GPS position data (latitude, longitude) with ApolloOne using the pin on the map. There are a number of ways
you can do this.

When you update the GPS position data, a backup copy of the original file will be saved. ApolloOne will append _original to
the file extension. For example, DSC_0862.JPG becomes DSC_0862.JPG_original. If you do not wish to have a backup
copy of the original file, you can turn it off by unchecking the setting under "Preferences... > Advanced > Backup original file
before making changes"

The following describe how you can update, add or delete GPS position data:

If the file has GPS position data, but you would like to change it:
Open the Inspector and go to the Map Info page
Select the file with the GPS position data you would like to change
Drag the pin to the new location on the map
Alternatively, you can also drop a new pin (also called marker) on the map.

If you are using Apple Maps, right mouse click or control mouse click on the map to bring up the context menu.
Select "Drop pin". A new pin will be dropped on the location of the right mouse click. To remove the pin, place
the mouse pointer on top of the pin, right mouse click to bring up the context menu, and select "Remove pin".
If you are using Google Maps, just click on the location where you want to place the pin, a new pin will be
created for you. If you click on another location, the last pin will be removed, and a new pin will be placed on the
new location you clicked.

Select menu "Camera Metadata > Copy GPS Data from Pin" (You can do this quickly by pressing the shortcut key
control-option-C)
Select menu "Camera Metadata > Write GPS Data" (You can do this quickly by pressing the shortcut key control-option-
W)

If you want to copy the GPS position data from another file to the current file:
Open the Inspector and go to the Map Info page
Select the file with the desired GPS position data
Select menu "Camera Metadata > Copy GPS Data from File" (You can do this quickly by pressing the shortcut key
control-option-F)
If you move the pin, you will need to Copy GPS Data from Pin instead of from the File
Select the file you wish to change or add the GPS position data
Select menu "Camera Metadata > Write GPS Data" (You can do this quickly by pressing the shortcut key control-option-
W)
You can repeat the above step by selecting another file

If you want to add GPS position data to a file without position data:
Open the Inspector and go to the Map Info page
Select the file without GPS position data that you would like to add position data with
A world map will be presented to you with a search field
Type the desired address or query and press enter
If Location Services is enabled, the search will use your current location with a 1.6Km radius to help narrow the search
results (this is only available with Apple Maps)
You may be presented with a single pin or multiple pins if the search criteria result in multiple locations
Drag the pin to the location you want
If there are multiple pins, the last pin you moved will be the location remembered by ApolloOne
Select menu "Camera Metadata > Copy GPS Data from Pin" (You can do this quickly by pressing the shortcut key
control-option-C)
Select menu "Camera Metadata > Write GPS Data" (You can do this quickly by pressing the shortcut key control-option-
W)
You can repeat the above step by selecting another file

If you want to delete GPS position data:

Editing GPS Position Data



Open the Inspector and go to the Map Info page
Select the file with the GPS position data you would like to delete
Select menu "Camera Metadata > Delete GPS Data" (You can do this quickly by pressing the shortcut key control-
option-D)

Handling of GPS position data for HEIC files:
If GPS position data are not present in the HEIC file, ApolloOne can add them via the XMP metadata group.
ApolloOne will always read the embedded XMP metadata in the HEIC file, and incorporate them into the overall metadata
structure.
You cannot display the XMP GPS coordinate data on iPhone or iPad when GPS coordinate data is added this way via
ApolloOne.

NOTE: When you copy GPS position data from a file, the altitude information will be preserved. If you drag the pin and copy
the pin position, the altitude information will be reset to zero.



ApolloOne has the ability to rotate an image or video.

You can rotate an image and most videos during playback. This can be easily done with the shortcut keys Shift-, for rotating
left (90 degrees counter-clockwise) and shortcut key Shift-. for rotating right (90 degrees clockwise).

For JPEG, HEIC and RAW images, this is accomplished by altering the EXIF:Orientation flag to indicate the new orientation.
This gives very fast rotation result.

For Bitmap (BMP), Portable Network Graphic (PNG) and Tagged Image File Format (TIFF), ApolloOne will perform rotation on
the image data, and then save the image data back to the file. Please note that a backup copy of the file will not be made for
image rotation operation.

For Graphics Interchange Format (GIF), only non-animated GIF files can be rotated. Animated GIF files will be left untouched
when you apply and save a rotation.

For video files, rotation is accomplished by adding a .xmp metadata file with the orientation infomation.

For Live Photo, the image portion of the file is rotated (typically this is JPEG or HEIC file), and the video portition will be
rotated by adding a .xmp file to include the orientation metadata, so that ApolloOne will know what orientation to use for Live
Photo playback.

When JPG+RAW Display Mode is enabled, both the JPG and RAW files will be rotated at the same time.

Rotate an Image or Video



There are serveral ways you can rename a file.

Method 1: Use the menu item "File > Rename..." to rename a file.

Method 2: Double click on the title bar where you see the file name.

Method 3: Click and hold down the mouse button on the file name you see in the thumbnail under Contact Sheet mode. After
about half a second, release the mouse and the field will be open for editing. Type a new file name and press the enter key or
click another location on the window to rename the file.

When you rename a file, such as JPEG, all associated files, such as RAW file, XMP sidecar file, and another other files with the
same name but different file extensions will also be renamed at the same time.

If you wish to rename more than one file, please refer to Batch Rename for more detail.

Renaming File



ApolloOne has a powerful, yet easy to use Batch Rename process that is designed specifically for digital cameras with RAW files and XMP sidecar files in mind. It also works with Live Photos, and
digital cameras with Voice Memo (.WAV) files. It allows multiple RAW files to be associated with the image and will rename them correctly.

To run Batch Rename, Full Version purchase is required. However, the renaming rules are free for trying, and you can perform a Test Run to see the Batch Rename result.

Batch Rename is available under the File menu when multiple thumbnails (files) are selected in the Contact Sheet mode. The "Rename..." menu item changes to "Batch Rename..." when you have
multiple thumbnails selected.

You can also activate the Batch Rename panel by double clicking the filename in the Toolbar area when multiple files are selected.

One of the nice features not available in other Batch Rename applications is that you can sort the files in the sequence you want first using the Sort menu, before applying the Batch Rename
process (see Tips and Hints below). The Sequence Number applied in the Batch Rename process will follow the sorting order of the files.

Another special feature is the ability to use Reverse Geocoding to find the City name and Country name using the image file's GPS coordinates metadata.

Elements of the Batch Rename panel

The Batch Rename panel has three sections of interest.

Templates section in which you can save the Rename Rules to templates, and you can store them under three different categories.
Rename Rules section in which you decide how you want the files to be renamed by adding rules.
Test Run Result secion in which you can see the result of the test run to see how the filenames would change when you cllick the Rename button to perform the actual Batch Rename.

Templates

Batch Rename



Templates can be stored in three categories: Favorites, For Images and For Videos. You can design specific templates for a particular category of files.

Click the [+] button to start working on a new template.

Click the [-] button to delete an existing template.

You can rename a template by double clicking on the template name.

You can rearrange the templates by dragging the template around, and you can drag a template from one category to another category.

Rename Rules
The section allows you to design the rename rules. There are eight main rules, and some of them has additional sub-rules.

The eight main rules are:

Original Filename
Date
Time
Timeline
Metadata
Sequence Number
Case Conversion
Text

The sub-rules allow further refinement of the main rules. Such as File Creation Date, Image Width, Camera Model, GPS > City, etc.

To add a new rule, click the [+] button underneath the rule editor. Once there is at least one rule in the editor, you can click the [+] or [-] button at the end of each rule to add or delete the rule.

NOTE: The Batch Rename process will rename the files in the sequence being display currently. Therefore, you can apply a particular sorting criteria (such as EXIF > Date Time
Digitized) , before you select the files for batch renaming.

Test Run Result
This is the output section containing the result of the Test Run.

You can inspect the current filenames and the corresponding new filenames in this section. You can hover the mouse pointer on each of the filename, a tooltip will popup showing the full path of the
file.

If the rename rules result in duplicate filenames, a number enclosed in parenthesis is appended to the filename, for example, filename(1), filename(2), etc.

You can also edit the new filename to give it a different name. Just click on the New filename field after you have selected the row. Edit the filename and press enter.

You may add a Sequence Number rule to ensure each file has a unique name.

Preserve original filename in XMP
Turn on this setting if you want to preserve the original filename in XMP:OriginalDocumentID tag. The original filename is saved in the XMP tag whether the Metadata source is set to "Use macOS
Extended Attributes" or "Combined both settings".

Special Rules/Sub-rules

Timeline
The Timeline rule performs calculation of time passed relative to the reference date. The reference date must be entered in YYYY-MM-DD format. This can be the birthday of a person or the starting
date of your vacation or event. The result can be displayed in a variety of formats.

The difference is computed using the reference date and the file's EXIF:DateTimeOriginal metadata. If the EXIF:DateTimeOriginal is not found, it will return an empty value.

If EXIF:DateTimeOriginal is earlier than the reference date, the value returned will be set to zero.

There are three special sub-rules under Timeline: Year part of YearMonthDay since, Month part of YearMonthDay since and Day part of YearMonthDay since. If YearMonthDay since
the reference date is 011224, then Day part of YearMonthDay since will return 24. Where Days would return 723 (the total number of days).

The sub-rules Day, Weeks, Months and Years have additional parameter. You can specify 2-digit format or 3-digit format for these Timeline criteria.

NOTE: The time portion in EXIF:DateTimeOriginal is not used for the calculation.



Reverse Geocoding
Under the Metadata rule, there are two special sub-rules: GPS > City and GPS > Country.

It uses the GPS coordinates metadata embedded in the image file, and apply a Reverse Geocoding process to obtain the City name and the Country name and apply the names as part of the new
filenames.

This is achieved by querying Apple's Reverse Geocoding server to obtain the result. Currently, Apple only allow 50 Reverse Geocoding requests for every 60 seconds (one minute). The result is
localized according to the user's language setup.

Because of this restriction imposed by Apple, you need to consider the time required for finding City and Country information when you rename a large number of files tagged with GPS metadata. If
you are renaming 500 files, the approximate time required for Reverse Geocoding is about 600 seconds or 10 minutes.

The Batch Rename caches the Reverse Geocoding requests, so that no redundant requests are made when the same GPS coordinates are found in the cache. This helps speed up the Reverse
Geocoding process for GPS coordinates that are exactly the same. This cache is cleared when you exit ApolloOne.

Fraction of a second Digitized Time
Under the Metadata > Digitized Time rule, there is a special sub-rule: HHMMSS_SSS

This rule extracts the EXIF.SubSecTimeOriginal metadata, and if it is present, it will be used to format the _SSS portion of the Digitized Time. Not all cameras record EXIF.SubSecTimeOriginal. If
this metadata is absent, _SSS portion will be filled with 000.

Handling of files with same name but different file extensions
It is possible for a camera to produce several files that are associated with the same image. You can get a JPEG file, a RAW file, a MOV file (Live Photos), and a WAV file (Voice Memo).

In addition, it is possible to convert a RAW file from the camera's native format to DNG RAW. And ApolloOne can also add an xmp sidecar file for video files or RAW file for the purpose of rotation.

When you apply a sequence number to the Batch Rename process, it intelligently treats all these files with different file extensions as a single file group. So they will have the same sequence
number at the time of rename, instead of having the sequence number incremented when file with the same name but with different file extension is encountered.

Tips and Hints
In order for Batch Rename to rename the files according to the sort order you specified, the first rule should start with a Sequence Number, followed by other rules. An example would look
something like this:

In the rename rules above, the new filename would look something like this: 049_Seattle_12-24.JPG

This will allow the files to be sorted in the default Filename sequence after Batch Rename has been performed.

Caching of metadata

When the Batch Rename process encounters a file without metadata as requested by the rules, it will apply the last cached values and apply that in the new filename. For example, it will apply City
/ Country name when an image file has no GPS coordinates metadata, but the previous file has them.



ApolloOne has a powerful, yet easy to use Batch Resize process to allow images to be reduced in size so you can use the
smaller images for web publishing, emails, and storage on iPhones and iPads.

It can also be used for file format conversion amongst JPEG, TIFF, PNG and HEIC. The source of the image files has to be
JPEG, TIFF, PNG, BMP or HEIC. Other image file formats are not supported. If you wish to resize a RAW image, use the
"Export Image as..." function and specify the resize options.

To run Batch Resize, Full Version purchase is required.

Batch Resize is available under the File menu for resizing images in the current file list.

You can also activate the Batch Resize function via file copy, which is the preferred method. This allows resized images to be
stored under a folder that is different than the current one.

This can be done via "File > Copy To" or drag-and-drop in Contact Sheet when the option key is held down when dropping the
files to a folder in the Folder Browser.

When you are using "File > Copy To", make sure the setting under "Preferences... > Advanced > Show confimation dialog
when moving and copying files" is checked. If this setting is unchecked, the dialog will not be prompted, and a simple file copy
operation is executed without the ability to specify the file resize option.

Elements of the Batch Resize panel (with file copy)

The Batch Resize function is activated when you click the check box "Resize image files at destination".

New size: This is where you specify the new image size. Default is to resize to 50% of the original. For example, a
6000x4000 image will be resized to 3000x2000 pixels. The choices are 100%, 75%, 50%, 33.33%, 25% and Custom.
When you select Custom, you can specify the custom size in % or in Pixels. When Pixels is selected, you specify the
longest dimension of the image. For a portrait image, this will be the longest height of the image you want after resize.
The resized image will always maintain the correct aspect ratio and orientation as the original image, whether it is a
landscape or portrait image. If you select 100%, the image dimension of the resized image will be the same as the
original, however, you can specify a different file format so that you can convert a JPEG image to TIFF for example.

Batch Resize and Format Conversion



Resolution: Default is 72 Pixels Per Inch (or commonly referred as DPI). You can change the unit to Pixels Per
Centimeter.
Filter: The default is Normal, which means no resampling filter is used. If you see jagged edges in your resized images,
you may want to use Lanczos filter instead.
Format: The format of the output file. Default is JPEG. You can select TIFF, PNG or HEIC.
Compression: The compression level of the output image. The higher the percentage, the better the image quality, but
the file size will be larger. This is only available when Format is set to JPEG or HEIC. With TIFF format, LZW is used for
image compression. Compression is automatic for PNG format.

NOTE: When you specify over 100% or very large pixels dimension for resizing, 100% will be used. This allows conversion of
the image to another format, or change DPI or compression ratio.



ApolloOne lets you to export images from one format into another. While performing the export, you have the option to resize
the images at the same time.

You can use this function to export a HEIC image into JPEG or even a RAW image into JPEG. You can export the image in four
file formats: JPEG, TIFF, PNG and HEIC.

You can use the RAW Adjustment panel to adjust the image display for the RAW file. When you export RAW files as JPEG, the
adjustment values for each individual image will be applied to the RAW file being exported. The exported file will use the same
color space of the original RAW file. If the original RAW files uses Adobe RGB color space, the exported file will also use Adobe
color space.

You can select multiple images in Contact Sheet mode, and export them in Batch Mode (Export Multiple Images as... in the
menu).

To run the Export Image function, Full Version purchase is required.

Elements of the "Export Image as..." panel

The Resize function is activated when you click the check box "Resize image files at destination".

New size: This is where you specify the new image size. Default is to resize to 50% of the original. For example, a
6000x4000 image will be resized to 3000x2000 pixels. The choices are 100%, 75%, 50%, 33.33%, 25% and Custom.
When you select Custom, you can specify the custom size in % or in Pixels. When Pixels is selected, you specify the
longest dimension of the image. For a portrait image, this will be the longest height of the image you want after resize.
The resized image will always maintain the correct aspect ratio and orientation as the original image, whether it is a
landscape or portrait image. If you select 100%, the image dimension of the resized image will be the same as the
original, however, you can specify a different file format so that you can convert a JPEG image to TIFF for example.
Resolution: Default is 72 Pixels Per Inch (or commonly referred as DPI). You can change the unit to Pixels Per
Centimeter.
Filter: The default is Normal, which means no resampling filter is used. If you see jagged edges in your resized images,
you may want to use Lanczos filter instead.
Format: The format of the output file. Default is JPEG. You can select TIFF, PNG or HEIC. If TIFF or PNG is selected, you
also have the option to export the image in 16-Bit (requires subscription or perpetual license purchase).
Compression: The compression level of the output image. The higher the percentage, the better the image quality, but

Exporting Images



the file size will be larger. This is only available when Format is set to JPEG or HEIC. With TIFF format, LZW is used for
image compression. Compression is automatic for PNG format.

NOTE: When you specify over 100% or very large pixels dimension for resizing, 100% will be used. This allows conversion of
the image to another format, or change DPI or compression ratio.



You can share photos and videos via the sharing feature.

You can either select "File > Share" from the menu or click the share button on the Toolbar or the lower left hand corner of
the main window if the Toolbar is hidden. A popup menu will be displayed, with the various sharing options.

You can share the current displayed photo or video via AirDrop or email.

ApolloOne will share the portion of the image being displayed in the window instead of the entire image file. You can zoom in
and pan around the image and share just that portion of the image in the display window1.

If you wish to share the entire image file in full resolution, first switch to Full Screen mode, and then click the share button.
You can switch to Full Screen mode quickly by double clicking the mouse pointer in the main window.

Video file will be uploaded entirely.

1. The entire image will be shared in Fluid Swipe mode.

File Sharing



You can share photos and videos to other Apple devices, such as iPhone, iPad using AirDrop.

You can either select "File > Share > AirDrop" from the menu or click the share button on the lower left hand corner of the
main window and select AirDrop.

Turn on AirDrop on your iPhone or iPad and make sure it is discoverable by your Macintosh computer.

Follow the instruction on your iPhone or iPad to complete the file transfer.

ApolloOne allows resizing and cropping when sending images via AirDrop. The resizing and cropping is only available in image
display mode.

When you AirDrop a single image in image display mode, the image is resized to the same size being displayed in the window
before it is being sent out via AirDrop. You can zoom in and pan around the image to the area of interest, and AirDrop will
simply share the cropped image instead.

Note: Avoid sharing large video files as the AirDrop connection is done via Bluetooth with a low transfer speed.

Sharing via AirDrop



ApolloOne has a very powerful Spotlight indexing feature. Once the fields are indexed by Spotlight, you can search for the photos or videos
simply by typing in a partial address or camera shooting data and Finder will locate all the files for you very quickly. You can press ⌘A in
Finder to select the entire search results, and drag-and-drop them into ApolloOne for viewing.

It helps to narrow down the search result by specifying additional search criteria, such as adding "Kind is Image" in the example below:

There are two types of data in which ApolloOne can index: address returned by the GPS Reverse Geocoding process (GPS address locator)
and EXIF data extracted from the file's metadata.

To enable the address data to be indexed, open "Preferences... > Geotagging & Indexing", check the "Lookup location data using GPS reverse
geocoding web service" setting and then follow by checking the "Index location data" setting.

To enable the camera shooting data to be indexed, open "Preferences... > Geotagging & Indexing", check the "Index EXIF data" setting and
choose the EXIF data fields you want for indexing. Currently, there are only 6 EXIF data fields that can be indexed.

The Index text example shows you the exact text of the EXIF index data that will be saved.

As you start to view photos using ApolloOne, all the location data and EXIF data will be indexed automatically based on the settings of this
preference page. The index will only be saved on the photos you have viewed.

To index all the photos in the current file list, you can use "Tools > Spotlight Indexing..." process. Select the fields you want to index, and
press the Start button. ApolloOne will perform indexing in a background process while you view photos and videos in the main window. You
can even open a new folder for viewing and it will not affect the list of files that are being indexed in the background.

Spotlight Indexing and Editing



If you wish to delete all the index data, you can select "Clear location index data" and/or "Clear EXIF index data" setting, and press the Start
button.

You can also edit the index data by selecting "Tools > Edit Spotlight Index Data..." from the menu. You get a floating window with the content
of the text you want to modify for indexing.

The "Save index data only if no index data exist" setting allows you to edit the index text with your own data so that the Spotlight Indexing
process will not overwrite the data that have been modified by you.



You can print your images via the Print... function under the File menu.

Contact Sheet Printing
You can select multiple images and print them as a Contact Sheet.

1. Go into Contact Sheet mode
2. Select the thumbnals (images) you want to print
3. Select the Print... function under the File menu
4. After the Print dialog box appeared, click the "Show Details" button and then change the drop down selection from

"AppolloOne" to "Layout"
5. Select the number of Pages per Sheet (you can select up to 16 images per sheet)
6. Select option "ApolloOne" to change "Auto Rotate", "Print File Name", "Print File Sequence Number", "Print Page Number"

and "Print Page Header" options as desired
7. Click the "Print" button

Printing



Here is a list of additional keyboard shortcuts supported by ApolloOne:

NOTE: The main display window must be in focus if you are pressing a shortcut key without a modifier key (ie: fn, control and
command keys).

Tab
Switches keyboard focus between the main window and the Folder Browser. You can navigate the Folder
Browser with the arrow keys.

Spacebar Advance to the next photo or video. In Contact Sheet mode, it opens the Quick Preview window.
fn ← Go to the first photo or video
fn → Go to the last photo or video
← Go to the previous photo or video
→ Go to the next photo or video
⌘[ Go to the previous photo or video
⌘] Go to the next photo or video
↑ Go to the previous photo or video
↓ Go to the next photo or video

alt ← Pan left
alt → Pan right
alt ↑ Pan up
alt ↓ Pan down

esc
Exiting Full Screen mode, toggle App Full Screen mode, stopping a slideshow, stopping a multi-file operation
(files deleting, files tagging, updating GPS data, etc.)

enter Toggle full screen (num pad enter key)
d 50% Zoom (same as control-5 shortcut key)

Shift - Zoom Out (in addition to the - key)
Shift + Zoom In (in addition to the = key)

+ Zoom In (num pad + key)
* Zoom to Fit (num pad * key)

fn ⌫ Move to Trash (this is the equivalent of the DEL key on a PC keyboard)
⌫ Move to Trash (after you enable "Preferences... > Startup & Delete > Delete files with backspace key)"

Additional Keyboard Shortcuts

In addition to the keyboard shortcuts, you can toggle full screen mode or Contact Sheet mode (depends on setting "Switch to
Contact Sheet mode by double clicking the main window" in Preferences) by double clicking the mouse by placing the mouse
pointer in the main window.



There are some special default values you can change to alter some of ApolloOne's behavior. These settings can only be
altered via the Terminal app.

Open the Terminal app under the Utilities folder and type the following ($ is the prompt, you do not need to type it) :

$ defaults write com.anogeissus.ApolloOne key value

Below is a list of keys and the values you can use.

MaxThumbnailSize
This key changes the maximum size you can have for the thumbnail in Contact Sheet mode.

The default value is 400 pixels. Any value less than 120 will be set to 120. Any value larger than 1264 will be set to 1264.

Example: defaults write com.anogeissus.ApolloOne MaxThumbnailSize 1264

ThumbnailHEICCompressionRatio
This key specifies the compression ratio for HEIC compressed thumbnails.

The default value is 0.4 for macOS Big Sur or later and 0.55 for macOS Catalina or earlier. The possible value range is 0.3 to
0.9.

Example: defaults write com.anogeissus.ApolloOne ThumbnailHEICCompressionRatio 0.5

DefaultCropCompressionRatio
This key specifies the compression ratio for the final image after cropping.

The default value is 0.85.

Example: defaults write com.anogeissus.ApolloOne DefaultCropCompressionRatio 0.95

DisableThumbnailRotationButtons
This key hides the thumbnail rotation buttons in Contact Sheet mode.

The default value is NO

Example: defaults write com.anogeissus.ApolloOne DisableThumbnailRotationButtons YES

HUDUIDelay
This key changes the delay time before the HUD (Headup Display) elements are displayed. This includes the Film strip, Folder
Browser and Inspector (in floating mode).

The default value is 0.5 (seconds). Any value less than 0 will be set to 0.01.

Example: defaults write com.anogeissus.ApolloOne HUDUIDelay 0.1

InfoWindowDisplayTime
This key changes the display time of the Info Window, where messages are displayed by ApolloOne, such as changing a color
tag or a rating.

The default value is 1.5 (seconds)

Example: defaults write com.anogeissus.ApolloOne InfoWindowDisplayTime 1.0

InfoWindowFadeoutTime
This key changes the fadeout time after the message is displayed in the Info Window.

Special User Defaults



The default value is 0.5 (seconds)

Example: defaults write com.anogeissus.ApolloOne InfoWindowFadeoutTime 0.3

HideProgressIndicator
This key allows the user to hide the file loading progress indicator in the main image display window.

The default value is NO

Example: defaults write com.anogeissus.ApolloOne HideProgressIndicator YES

DisableMomentumScrollingForThirdPartyMouse
This key disable the momentum scrolling for third party mouse in three places: Folder Browser, Contact Sheet and Inspector
Detailed Info page.

The default value is NO

Example: defaults write com.anogeissus.ApolloOne DisableMomentumScrollingForThirdPartyMouse YES

PreserveMakerNotesAfterCrop
This key allows the user to preserve the MakerNotes metadata after a Crop Image operation. When image is cropped, the AF
Points metadata stored in MakerNotes will not be correctly reflecting the AF points of the original image, and therefore, all
MakerNotes metadata are removed. However, you can preserve the MakerNotes if you understood that the AF points
metadata would be incorrect after a crop.

The default value is NO

Example: defaults write com.anogeissus.ApolloOne PreserveMakerNotesAfterCrop YES

EnableGPUFaceDetection
This key allows the use of GPU (Graphics Processing Unit) for performing face detection in the image, when face detect focus
metadata is absent.

The default value is NO

Example: defaults write com.anogeissus.ApolloOne EnableGPUFaceDetection YES

TrackPadPressureThresholdFor2xMagnification
This key controls the amount of pressure needed for the magnifier to switch to 200% magnification.

The default value is 0.75. The valid value range is 0.1 to 0.9.

Example: defaults write com.anogeissus.ApolloOne TrackPadPressureThresholdFor2xMagnification 0.8

EnableContactSheetTransitionEffect
This key tells ApolloOne to enable or disable transition animation when switching in and out of Contact Sheet mode.

The default value is YES

Example: defaults write com.anogeissus.ApolloOne EnableContactSheetTransitionEffect NO

ContactSheetTransitionEffectTime
This key controls the transition effect time when the effect is enabled.

The default value is 0.1 (seconds).Any value less than 0.08 will be set to 0.08. Any value greater than 0.5 will be set to 0.5.

Example: defaults write com.anogeissus.ApolloOne ContactSheetTransitionEffectTime 0.2

RescanAfterSubfolderLevelChange



This key controls whether a folder rescan should occur after changing Include Subfolders level.

The default value is NO

Example: defaults write com.anogeissus.ApolloOne RescanAfterSubfolderLevelChange YES

SynchronousImageLoad
This key controls whether synchronous image loading is desired. If you observe any image tearing when cycling to the next
image quickly, you may want to turn this on.

Turning this setting on may make the UI non-responsive for loading complex/large images.

The default value is NO

Example: defaults write com.anogeissus.ApolloOne SynchronousImageLoad YES

DefaultCropOverlayGridLineWidth
This key controls the line width of the grid lines display in crop mode overlay.

The default value is 1.0 (1-point or 1/72 inch), available range 1.0 - 3.0.

Example: defaults write com.anogeissus.ApolloOne DefaultCropOverlayGridLineWidth 2.0

DefaultCroppingMaskAlpha
This key controls the transparency (darkness) of the mask outside of the crop area.

The default value is 0.4, available range 0.1 (light) - 0.9 (dark).

Example: defaults write com.anogeissus.ApolloOne DefaultCroppingMaskAlpha 0.8



Operating system: macOS 10.12 Sierra, 10.13 High Sierra, 10.14 Mojave, 10.15 Catalina, 11 Big Sur, 12 Monterey, 13
Ventura, 14 Sonoma, 15 Sequoia.

CPU: Intel x86 and Apple Silicon CPUs.

Memory: 4GB minimum; 8GB recommended.

Input device: Apple Trackpad or Magic Mouse recommended

Application limitations:

ApolloOne is limited to opening up to 200,000 thumbnails at once. This is more of a practical limit to ensure the
application is running smoothly.
Drag-and-drop does not work in Fluid Swipe mode.

Requirements and Limitations

Please email us for any suggestions or language translation improvements.

mailto:support@anogeissus.com


What's new with version 3.8.0:
Apple RAW Decoder support for Fujifilm GFX100RF.
Adds support for 14-bit Olympus ORF files.
Adds AF Point support for Nikon Z5 II.
Adds Sigma .X3F support for the memory card import process.
Underexposure fix for Fujifilm uncompressed RAF file with DR200/400.
Bug fix for file index reset when tagging files in filter mode.
Updates LibRaw to version 202502.
Updates ExifTool to version 13.29.
Updates MediaInfo to version 25.04.
Various improvements and bug fixes.

What's new with version 3.7.4:
Bug fixes.

What's new with version 3.7.3:
NEW! Adds the ability for user defined shortcut keys for changing color tag and rating.
NEW! Add Folder to Places context menu.
Adds the ability to disable Navigation Panel under Advanced Settings.
Bug fix for Canon .CR3 decoder.
Work around Apple RAW Decoder bug for Leica M Monochrom DNG image under macOS Sonoma and Sequoia.
Updates ExifTool to version 13.25.
Various improvements and bug fixes.

What's new with version 3.7.2:
Updates ExifTool to version 13.18.
Bug fixes.

What's new with version 3.7.1:
NEW! Navigator panel to show an overview of the image when performing image zoom and pan.
Allows Overexposure and underexposure display for any images1.
Updates ExifTool to version 13.17.
Improvements and bug fixes.

What's new with version 3.7.0:
NEW! Adds contrast, saturation and vibrance controls in the RAW Adjustment panel.
NEW! Overexposure and underexposure display for RAW images1.
NEW! AF Point support for Nikon Zf, Z50 II and Z6 III1.
NEW! Auto hide mouse pointer in full screen mode.
Updates ExifTool to version 13.12.
Various improvements and bug fixes.

What's new with version 3.6.9:
Updates ExifTool to version 13.03.
Updates MediaInfo to version 24.11.
Regression bug fixes.

What's new with version 3.6.8:

NEW! Apple RAW Engine support for Olympus OM-1 Mark II and OM-52.

Revision History



Regression bug fixes.

What's new with version 3.6.7:

NEW! Apple RAW Engine support for Fujifilm X-M52.
Bug fix for Canon .CR3 decoder.
Updates ExifTool to version 12.98.
Various improvements and bug fixes.

What's new with version 3.6.6:
Supports the display of iPhone JPEG XL DNG container for macOS Ventura or lower.
Enhancements to tagging and rating subsystems.
Bug fix for printing subsystem.
Updates ExifTool to version 12.97.
Various improvements and bug fixes.

What's new with version 3.6.5:
NEW! Random sorting (Standard and Pro Edition only).
Enhancements and bug fixes for Folder Browser.
Regression bug fix for thumbnails and image mismatch when Sort order is not by File Name on startup.
Various improvements and bug fixes.

What's new with version 3.6.4:
NEW! Adds Sigma Foveon X3F support.
NEW! Adds "Move all Filtered Files to Trash" function under the Filter menu.
Adds Nikon Crop Mode support for HE/HE* compressed NEF files.
Adds momentum scrolling for 3rd party mouse with scroll wheel.
Bug fix for metadata database synchronization.
Enhancements and bug fixes for file import.
Updates ExifTool to version 12.96.

What's new with version 3.6.3:
Bug fix for displaying Fujifilm X-Trans CMOS III compressed RAF files.

What's new with version 3.6.2:
Adds Canon R5m2 and R1 CR3 files support.
Adds Nikon Z6 III HE/HE* NEF files support2.
Improves Nikon HE/HE* NEF files processing.
Updates ExifTool to version 12.92.
Bug fixes.

What's new with version 3.6.1:
Updates ExifTool to version 12.89.
Bug fixes.

What's new with version 3.6.0:
NEW! Apple RAW Engine support for Nikon HE/HE* NEF files.
NEW! Apple RAW Engine support for compressed Fujifilm RAF files.
NEW! Performance improvement for decoding compressed Fujifilm RAF files (4x decoder speedup).
NEW! Performance improvement for decoding Canon RAW files (3x decoder speedup).
Updates ExifTool to version 12.87.
Updates MediaInfo to version 24.06.
Various improvements and bug fixes.



What's new with version 3.5.0:
NEW! User customizable Shortcut Keys (Pro Edition only).
NEW! Undo file delete function.
NEW! Duplicate Folder function (Folder Browser's context menu).
NEW! Sort folders by ascending or descending order (Folder Browser's context menu).
Improves the handling of aliases and symlinks (Standard Edition only).
Updates ExifTool to version 12.85.
Updates MediaInfo to version 24.04.
Various improvements and bug fixes.

What's new with version 3.4.0:
NEW! Toolbar with Icon and Text support.
Enhanced Batch Rename Original filename rule.
Improves Import Files functions.
Revamped Nikon Z AF Point display function.
Regression bug fixes.
Updates LibRaw to version 202403.
Updates ExifTool to version 12.82.
Updates MediaInfo to version 24.03.

What's new with version 3.3.9:
NEW! Support for JPEG XL (.JXL) for macOS Sonoma.
Automatically refreshes file filter when folder scan is complete.
Finder labels synchronization code update with macOS Sonoma.
Updates ExifTool to version 12.77.
Updates MediaInfo to version 24.01.

What's new with version 3.3.8:
Bug fix with SavedSearch function for not searching in a specific folder.
Updates ExifTool to version 12.73.

What's new with version 3.3.7:
Enhancements and bug fixes.

What's new with version 3.3.6:
NEW! Slideshow time interval can be changed with up/down arrow keys when the slideshow is running.
Updates ExifTool to version 12.70.
Updates MediaInfo to version 23.11.

What's new with version 3.3.5:
Bug fixes.

What's new with version 3.3.4:
Updates ExifTool to version 12.69.
Enhancements and bug fixes.

What's new with version 3.3.3:
Enhancements and bug fixes.

What's new with version 3.3.2:
NEW! Option to save thumbnails in HEIC format to save space (under Preferences > Advanced).
NEW! Auto RAW engine switching with Apple ProRAW files.



Updates ExifTool to version 12.68.
Updates MediaInfo to version 23.10.
Enhancements and Bug fixes.

What's new with version 3.3.1:
Improves the functionality of the Inspector Filters.
Enhancements and Bug fixes.

What's new with version 3.3.0:

NEW! Metadata template functions2.
Reorganizes EXIF Toolbox menu items under Camera Metadata and User Metadata menus.
Restores Finder labels synchronization functionality with macOS Monterey and later versions of macOS.
Display engine optimizations.
Enhances the Import Files process.
Bug fix for incorrect value for DateCreated in XMP file.
Updates ExifTool to version 12.67.
Updates MediaInfo to version 23.09.
Removes RawSpeed 3 support.
Enhancements and Bug fixes.

What's new with version 3.2.8:
NEW! RGB color values display (next to Histogram) for pixel under the mouse pointer.
Updates ExifTool to version 12.64.
Updates MediaInfo to version 23.06.
Enhancements and Bug fixes.

What's new with version 3.2.7:
NEW! Record slideshow output to a video file (Pro Edition only).
Adds drag-and-drop support for thumbnails in the filmstrip to one of the views in Split View.
Enhancements and Bug fixes.

What's new with version 3.2.6:
Enhancements and Bug fixes.

What's new with version 3.2.5:
New File Types filter and reorganized Filter menu.
New settings for slideshow.
Improves image display speed by 100% and reduces memory usage by 50% for Apple Silicon Macs.
Updates ExifTool to version 12.62.
Updates MediaInfo to version 23.04.
Enhancements and bug fixes.

What's new with version 3.2.4:
Updates ExifTool to version 12.60.
Updates MediaInfo to version 23.03.
Enhancements and bug fixes.

What's new with version 3.2.3:
NEW! GoPro GPR RAW files support.
Enhancements and bug fixes.

What's new with version 3.2.2:
Updates ExifTool to version 12.57.

file:///Users/albert/Dropbox/Dev/ApolloOne/ApolloOne/ApolloOne.help/Contents/Resources/en.lproj/pgs/pgs/camera-metadata.html
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Bug fixes.

What's new with version 3.2.1:
Bug fixes.

What's new with version 3.2.0:
NEW! Advanced Import Options (Pro Edition only).
NEW! Zoom to Fit Width and Zoom to Fit Height functions under the View menu.
NEW! Video scrubbing for video thumbnails in Contact Sheet mode.
NEW! Live Photos playback for thumbnails in Contact Sheet mode.
NEW! Sony Pixel Shift (ARQ) files support.
NEW! Pixelmator (PXD) files support (QuickLook image only).
Multi-core processing when exporting multiple images (Standard and Pro Editions).
Multi-core processing when saving metadata with Edit Metadata dialog (Standard and Pro Editions).
Horizontally or vertically flipped image states are now saved.
Updates LibRaw to 0.21.1 with RawSpeed 3.
Updates ExifTool to version 12.56.
Enhancements and bug fixes.

What's new with version 3.1.10:
NEW! Grid lines in crop mode.
Updates ExifTool to version 12.51.
Enhancements and bug fixes.

What's new with version 3.1.9:
Updates ExifTool to version 12.50.
Enhancements and bug fixes.

What's new with version 3.1.8:
NEW! Delete originals from memory card after file import.
Hot fix for app crash when toggling full screen with the enter key.

What's new with version 3.1.7:
NEW! Automatic display of checkerboard pattern in the image background if transparency is detected.
Improves zoom in and zoom out performance.
Improves image display pipeline.
Updates ExifTool to version 12.49.
Enhancements and bug fixes.

What's new with version 3.1.6:
Compatibility fixes for macOS Ventura.
Updates MediaInfo library to 22.09.
Updates ExifTool to version 12.47.
Enhancements and bug fixes.

What's new with version 3.1.5:
NEW! 16-Bit export for TIFF and PNG file formats (requires Pro subscription or Pro perpetual license purchase).
Enhancements and bug fixes.

What's new with version 3.1.4:
NEW! Import Files Toolbar button.
NEW! Option to eject memory card when finished importing files.
Performance improvement for opening folders with more than 50000 files.



Enhancements and bug fixes.

What's new with version 3.1.3:
NEW! Keeps sort setting on a per folder basis (requires subscription or perpetual license purchase).
NEW! Image rotation buttons directly accessible on the thumbnails in Contact Sheet mode.
Enhancements and bug fixes.

What's new with version 3.1.2:
NEW! Refresh All Thumbnails with multi-core processing (requires subscription or perpetual license purchase).
NEW! Setting to disable the processing of Live Photos.
Updates ExifTool to version 12.44.
Enhancements and bug fixes.

What's new with version 3.1.1:
NEW! Sort by User Defined Sequence (requires subscription or perpetual license purchase).
NEW! Display file name preferences setting for slideshow.
Extends support for .HEIF and .HIF files.
Bug fix for file import process.
Updates ExifTool to version 12.43.
Enhancements and bug fixes.

What's new with version 3.1.0:
NEW! Nikon Z9 Show AF Points support.
NEW! Unsharp Mask filter in RAW Adjustment panel.
Enhancements and bug fixes.

What's new with version 3.0.9:
Enabled keyboard control for video controller during video playback (please see Shortcut keys under Video playback in the
Help book for details).
Updates ExifTool to version 12.42.
Bug fixes.

What's new with version 3.0.8:
NEW! + or - prefix in keywords in Edit Metadata panel for adding or removing keywords with multiple files selection.
Enhancements and bug fixes.

What's new with version 3.0.7:
NEW! "Add IPTC / XMP Tags..." utility panel (requires subscription or perpetual license purchase).
Enhancements and bug fixes.

What's new with version 3.0.6:
Adds wide gamut image support, requires P3 color space capable displays.
Adds support for OM System RAW files.
Performance optimization for Apple Silicon.
Improves performance for network folders.
Updates MediaInfo library to 22.03.
Updates ExifTool to version 12.41.
Enhancements and bug fixes.

What's new with version 3.0.5:
Enables Perpetual License purchase.
Updates XMP Toolkit to 2022.02.
Enhancements and bug fixes.



What's new with version 3.0.4:
Updates ExifTool to version 12.40.
Enhancements and bug fixes.

What's new with version 3.0.3:
NEW! Adds support to display Affinity Photo .afphoto files (thumbnail preview image only).
NEW! Option to decode RAW files using Apple RAW image decoder.
Minor bug fixes.

What's new with version 3.0.2:
Minor bug fixes.

What's new with version 3.0.1:
Minor bug fixes.

What's new with version 3.0.0:
NEW! Batch Image Resize and Format Conversion function.
NEW! Batch image export.
NEW! Crop, resize and export images in HEIC format.
NEW! Import files from memory cards.
NEW! Combine JPEG+RAW, Files other than RAW, RAW Only and All Files Display Modes.
NEW! Split View for side-by-side image comparison.
NEW! EXIF Toolbox functions: Set EXIF Digitized Date to File Creation Date and Sync XMP Sidecar File to Image.
NEW! Browsing History for quickly switching between multiple events or projects.
NEW! Favorite Exif Tags in the Inspector.
NEW! Search files with any Exif Tags in the Inspector with RegEx support.
NEW! Keywords Management and Keywords Filter in the Inspector.
NEW! Original Filename and Timeline rules for Batch Rename.
NEW! Color temperature and tint adjustments for RAW images.
NEW! Filters for video files, RAW files, GPS Distance Measurement, GPS Altitude Distance and inverting filter.
NEW! GPS Display Format selections and GPS Distance Measurement functions.
NEW! "New Folder with Selection" in the Browser's context menu.
Enhanced print options.
Enhanced "Edit Metadata..." functionality.
Direct file rename from the thumbnail.
Improves file deletion functionality.
Updates Exiv2 to version 0.27.5.
Updates MediaInfo to version 21.09.
Updates ExifTool to version 12.39.
Enhancements and bug fixes.

What's new with version 2.9.9:
NEW! WebP file type support under Big Sur.
Bug fix for altering creation date metadata when adding GPS metadata to videos.
Bug fix for Live Photos detection.
Updates ExifTool to version 12.29.
Enhancements and bug fixes.

What's new with version 2.9.8:
NEW! Multi-image Contact Sheet printing.
Improves file caching performance.
Bug fix for resolving folder alias and file alias in Edit Metadata.
Bug fix for blank video playback and video rotation.
Updates ExifTool to version 12.28.



Enhancements and bug fixes.

What's new with version 2.9.7:
Improves RAW image rendering.
Updates ExifTool to version 12.26.
Enhancements and bug fixes.

What's new with version 2.9.6:
Updates ExifTool to version 12.25.
Bug fixes.

What's new with version 2.9.5:
NEW! Adds searching by Folder Name or Metadata.
NEW! Adds multiple folders selection for Folder Browser.
NEW! Adds file delete confirmation dialog.
NEW! Adds "Rename Duplicate Files" option in Copy / Move files dialog.
NEW! Adds Subsecond handling to Batch Rename.
NEW! Adds NoWrapAround to Special User Defaults.
Updates MediaInfo library to version 21.03.
Updates ExifTool to version 12.23.
Enhancements and bug fixes.

What's new with version 2.9.4:
NEW! Adds setting to allow complete video playback during slideshow.
NEW! Adds setting for displaying Description metadata during slideshow.
NEW! Adds support for laser presenter, such as Logitech R400.
Reassigns a few shortcut keys to support laser presenters.
Updates ExifTool to version 12.21.
Enhancements and bug fixes.

What's new with version 2.9.3:
NEW! Enhanced image cropping function.
NEW! Restore Image to Original function (if backup is enabled in Preferences).
NEW! RAW engine updated to support lossy compressed CR3 and RAF files. Adds support for newer cameras.
Adds HideProgressIndicator and PreserveMakerNotesAfterCrop to Special User Defaults.
Updates ExifTool to version 12.16.
Enhancements and bug fixes.

What's new with version 2.9.2:
NEW! Adds image cropping function (requires Full Version purchase).
Updates ExifTool to version 12.13.
Enhancements and bug fixes.

What's new with version 2.9.1:
Bug fixes.

What's new with version 2.9.0:
NEW! Adds Apple Silicon (M1) support.
NEW! Batch Rename (requires Full Version purchase).
NEW! Folder scanning progress panel.
Updates ExifTool to version 12.12.
Enhancements and bug fixes.

What's new with version 2.8.4:



NEW! Adds printing support.
NEW! Adds RAW Adjustments panel.
NEW! Adds Polish language translation.
Updates ExifTool to version 12.09.
Bug fixes.

What's new with version 2.8.3:
NEW! AF Point support for Canon EOS R, RP, R5, R6, Nikon Z50, Z5, Z6 II and Z7 II.
NEW! Adds faces detection when there are no faces metadata in the image.
Updates XMPTool Kit to version 6.0.0.
Updates LibRaw to version 0.20.2.
Updates ExifTool to version 12.08.
Enhancements and bug fixes.

What's new with version 2.8.2:
NEW! Videos can now be played back during slideshow.
NEW! Tagging of folders with Finder color tags.
NEW! Exposure adjustment slider (for RAW images only).
NEW! Auto Tone Curve menu item and faster RAW converter performance.
Updates ExifTool to version 12.07.
Enhancements and bug fixes.

What's new with version 2.8.1:
Bug fixes.

What's new with version 2.8.0:
NEW! Clicking and holding down the mouse or TrackPad button in the main window activates the magnifier.
NEW! Live Photo support.
NEW! Full Screen mode without sidebar panels.
NEW! Synchronization with Finder labels.
New settings in Preferences > Advanced setup.
Adds TrackPadPressureThresholdFor2xMagnification to Special User Defaults.
Defaults.
Adds Shift + mouse click function in Contact Sheet mode.
Remembers the state of Auto Advance mode on startup.
Updates ExifTool to version 12.06.
Enhancements and bug fixes.

What's new with version 2.7.0:
NEW! Adds "Loop video playback" setting to Preferences.
NEW! Edits metadata on multiple files using Edit Metadata dialog (requires Full Version purchase).
Redesigns thumbnail loading engine for faster thumbnail load speed on slow disk or network devices.
Updates LibRaw to version 0.20.
Updates ExifTool to version 12.03.
Enhancements and bug fixes.

What's new with version 2.6.4:
Bug fixes.

What's new with version 2.6.3:
Enhancements and minor bug fixes.

What's new with version 2.6.2:
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Window will maintain its width when hiding Folder Browser or Inspector if window was set to "Zoom to Fit Screen Width".
Adds alternate Inspector icons setting (Preferences... > Appearance).
Updates Exiv2 library to v0.27.3.
Various enhancements and bug fixes.

What's new with version 2.6.1:
Fixes a bug where user may experience an app crash under macOS Catalina when deleting a file.
Updates ExifTool to version 12.01.
Various enhancements and bug fixes.

What's new with version 2.6.0:
NEW! Contact Sheet completely re-written for unprecedented speed in opening folders with thousands of images.
NEW! Smart Folder support. You can now view files using Finder saved searches, just add the Saved Searches folder to
Places.
NEW! Adjust thumbnail size by moving the handle bar above the Filmstrip.
NEW! EXIF Toolbox with 9 new tools. You can now set file creation date based on the metadata, and much more.
NEW! Export RAW image as JPEG.
NEW! Support for AF Point display for Olympus OM-D cameras.
Locating the corresponding RAW file against a JPEG file is enhanced to search for one level deep subfolders from within
the folder where the JPEG resides.
Speeds up network folder access.
Updates ExifTool to version 12.00.
Various enhancements and bug fixes.

What's new with version 2.5.0:
Changes the default behavior of double click to zoom toggle instead of switching to Contact Sheet.
Fixes a bug causing one-month trial to expire immediately for users in the non-English region.
Updates ExifTool to version 11.99.
Removes support for macOS 10.10 and 10.11.

What's new with version 2.4.9:
Enables display of AF point on Nikon D-SLRs in Contrast Detect AF mode.
Improves image resolution when previewing RAW files.
Updates Exiv2 library to 0.27.3.1.
Updates ExifTool to version 11.98.
Improves French translations.
Bug fixes.

What's new with version 2.4.8:
Updates ExifTool to version 11.97.
Bug fixes.

What's new with version 2.4.7:
Updates ExifTool to version 11.94.
Updates MediaInfo library to version 20.03.
Improves French translations.
Bug fixes.

What's new with version 2.4.6:
Updates ExifTool to version 11.93.
Bug fixes.

What's new with version 2.4.5:
Updates ExifTool to version 11.91.



Bug fixes.

What's new with version 2.4.4:
Bring window to the foreground during slideshow when the external monitor is reconnected.
Updates ExifTool to version 11.90.
Various enhancements and bug fixes.

What's new with version 2.4.3:
New setting for 1:1 pixel mapping for Retina Display.
Updates ExifTool to version 11.89.
Various enhancements and bug fixes.

What's new with version 2.4.2:
Adds "New Folder" and "Delete Folder" functions in the Folder Browser's context menu.
Improves the usability of the Folder Browser's conext menu.
File cache is now configurable from 2 to 16.
Adds AF Points support for Nikon D780.
Updates ExifTool to version 11.84.
Bug fixes.

What's new with version 2.4.1:
Updates ExifTool to version 11.81.
Bug fixes.

What's new with version 2.4.0:
Adds AF Points support for Nikon D80, D90, D3X, D200, D300, D300s, D3000, D3100, D3200, D3300, D3500, D5000,
D5100, D7100, D7200, D7500, Z50, Z6 and Z7 cameras.
Native support for decoding Canon .CR3 RAW files.
Adds support for selecting subfolders depth.
Updates ExifTool to version 11.80.
Improves French, German, Dutch and Japanese translations.
Various enhancements and bug fixes.

What's new with version 2.3.9:
Updates ExifTool to version 11.53.
Enhanced compatibility with NAS folders.
Minor bug fixes.

What's new with version 2.3.8:
Adds "Tools > Refresh Selected Thumbnails" menu item.
Adds image file alias support (requires Full Version Upgrade).
Updates ExifTool to version 11.45.
Minor bug fixes.

What's new with version 2.3.7:
Adds support for Canon .CR3 RAW files.
"Copy To" and "Move To" can perform multiple files copying/moving in Contact Sheet mode.
Updates ExifTool to version 11.42.
Various enhancements and bug fixes.

What's new with version 2.3.6:
Adds "Copy To" and "Move To" shortcut submenus.
Adds the ability to edit the metadata of HEIC files.



Updates ExifTool to version 11.34.
Minor bug fixes.

What's new with version 2.3.5:
Updates ExifTool to version 11.32.
Minor bug fixes.

What's new with version 2.3.4:
Adds EXIF.SubSecTimeOriginal support when sorting files with EXIF > Date time digitized.
Updates ExifTool to version 11.31.
Minor bug fixes.

What's new with version 2.3.3:
Fixes an issue with slow loading of very large images.
Updates ExifTool to version 11.30.

What's new with version 2.3.2:
Zoom Toggle now magnifies under the location of the mouse pointer.
Updates ExifTool to version 11.29.
Minor bug fixes.

What's new with version 2.3.1:
Adds Drop pin/marker feature to Apple Maps and Google Maps.
Updates ExifTool to version 11.28.
Various enhancements and bug fixes.

What's new with version 2.3.0:
NEW! User defined Metadata Source for managing metadata.
NEW! Rotate multiple images in Contact Sheet mode (full version purchase required).
NEW! Edit macOS Extended Attributes/IPTC/XMP metadata (see "Edit > Edit Metadata").
NEW! User defined custom labels for Finder tags (see Preferences... > Metadata).
NEW! Inspector File Filter panel.
Extended attributes are now fully preserved when updating an image file's metadata.
Updates RAW engine to support more cameras.
Updates ExifTool to version 11.27.
Various enhancements and bug fixes.

What's new with version 2.2.4:
Files filtering code has been completely rewritten.
Updates ExifTool to version 11.23.
Various enhancements and bug fixes.

What's new with version 2.2.3:
Adds Quick Preview of image in Contact Sheet mode (just press the spacebar like QuickLook).
Updates ExifTool to version 11.22.
Updates MediaInfo library to version 18.12.
Various enhancements and bug fixes.

What's new with version 2.2.2:
Fixes a crash under macOS 10.10.
Fixes a bug for users who have purchased version 1 were not automatically upgraded to version 2.

What's new with version 2.2.1:



Fixes an issue with slowness in generating thumbnails for camera RAW files.

What's new with version 2.2.0:
Allows slideshow transition time of 0.0 second so that the transition effect can be skipped.
Thumbnails can now be resized. Added database for storing the thumbnails.
You can rename the file by double clicking the filename in the Toolbar.
Updates ExifTool to version 11.20.
Various enhancements and bug fixes.

What's new with version 2.1.3:
Improves macOS Mojave dark mode support (Preferences... > Appearance).
Adds drag-and-drop support for Contact Sheet and Folder Browser.
Adds Search field for locating or filtering files (Available under the Toolbar).
You can now hide the Filmstrip (Tools > Hide Filmstrip).
You can now add folders to Places in the free version of the app.
Updates ExifTool to version 11.16.
Various enhancements and bug fixes.

What's new with version 2.1.2:
Adds macOS Mojave support.
Updates ExifTool to version 11.11.
Various enhancements and bug fixes.

What's new with version 2.1.1:
Updates MediaInfo library to version 18.08.1.
Various enhancements and bug fixes.

What's new with version 2.1.0:
Adds viewing support for Adobe PSD files.
Updates ExifTool to version 11.10.
Various enhancements and bug fixes.

What's new with version 2.0.9:
Improves image zoom performance.
Updates ExifTool to version 11.03.
Various enhancements and bug fixes.

What's new with version 2.0.8:
Adds option for image zooming with mouse scroll wheel.
Improves the dragging function when dragging an image out of the display window (please see drag-and-drop section for
detail).
Improves support for forward/backward mouse buttons for image navigation.
Improves star rating shortcut keys.
Updates ExifTool to version 10.98.
Various enhancements and bug fixes.

What's new with version 2.0.7:
Adds option to arrange folders by creation date.
Adds support for forward/backward mouse buttons for image navigation.
Improves Japanese translations.
Updates ExifTool to version 10.93.
Various enhancements and bug fixes.



What's new with version 2.0.6:
Adds folder rename function.
Updates ExifTool to version 10.80.
Various enhancements and bug fixes.

What's new with version 2.0.5:
Adds support for dragging an image URL from a web browser into the main window. The image will be downloaded and
displayed for you.
Updates ExifTool to version 10.76.
Various enhancements and bug fixes.

What's new with version 2.0.4:
Auto Advance mode will now act as camera tethering mode by displaying the newly captured image if camera tethering
plug-in software writes the image file into the folder being viewed by ApolloOne.
New Advanced option for switching to Contact Sheet by double clicking on the main window.
GPS marker is now displayed on video thumbnails.
Histogram can now be displayed in full on Macbook Air/Pro with 900/1800 dots vertical resolution.
Updates ExifTool to version 10.77.
Various enhancements and bug fixes.

What's new with version 2.0.3:
Added Shuffle Playback for slideshow (requires Full Version Upgrade).
Updates ExifTool to version 10.67.
Performance improvements and bug fixes.

What's new with version 2.0.2:
New: You can now edit metadata (EXIF, MakerNotes, IPTC, XMP) easily using the Inspector (requires Full Version
Upgrade).
Fixed a bug where the keywords are wiped out after changing Rating/GEO Tagging.
Updates ExifTool to version 10.65.
Performance improvements and bug fixes.

What's new with version 2.0.1:
Added slideshow controller and slideshow music playback.
Added GPS marker in thumbnails when GPS coordinate data are detected in the files.
Added file filtering for files with or without GPS data.
Fixed a crash experienced by some users when migrating from the previous version of the app.
Updates ExifTool to version 10.64.
Performance improvements and bug fixes.

What's new with version 2.0.0:
ApolloOne is now free to download and the advanced features are unlocked via In-App Purchase.
New user configurable Places in the folder Browser (requires In-App Purchase).
New Auto Advance mode, allows fast culling of images.
New horizontal bar mode for the Filmstrip.
New settings under Advanced setup.
New built-in RAW decoder. You can now see the image data as captured by the camera's sensor.
New Toolbar items: Finder Tag filter, Rating filter, and built-in RAW decoder on/off toggle.
Adds support for HEIF images and HEVC videos on macOS High Sierra.
Adds support for XMP sidecar file for videos and camera RAW files. It is now compatible with XML files created by other
photo editing applications.
Adds implicit auto saving of EXIF orientation value if user changes the orientation of JPEG or RAW files.
File creation date is now preserved after Rating, GPS data update.
Updates ExifTool to version 10.63.
Performance improvements and bug fixes.



What's new with version 1.8.5:
Adds Histogram to Inspector.
Adds mouse drag for multiple thumbnails selection in Contact Sheet mode.
Copy/Move/Trash/Remove Tags/Remove Ratings/File Sharing (such as AirDrop) will work with multiple selected
thumbnails in Contact Sheet mode.
Files can be pasted into Finder by first using Edit > Copy for the selected thumbnails in Contact Sheet mode.
Updates ExitTool to version 10.57.
Performance improvements and bug fixes.

What's new with version 1.8.4:
Performance improvements and bug fixes.

What's new with version 1.8.3:
Updates ExitTool to version 10.55.
UI improvements and bug fixes.

What's new with version 1.8.2:
Adds Contact Sheet for displaying all thumbnails in the window.
You can select multiple files in Contact Sheet and perform operations on them (delete, file tagging, etc.)
Updates ExitTool to version 10.54.

What's new with version 1.8.1:
Delay time between slides is now up to 60 seconds.
You can now update GPS coordinates for video files.
You can now use network folder as Library location.
You can now access folder aliases and symbolic links in the Browser.
UI improvements and bug fixes.
Updates ExitTool to version 10.53.

What's new with version 1.8.0:
Adds user customizable Toolbar.
Adds Star Rating, and associated functions.
Adds Voice Memo playback. Deleting a photo will also delete the Voice Memo.
Content of the window (image or video) can be dragged into another application.
Updates ExitTool to version 10.48.

What's new with version 1.7.3:
Fixes a long overdue bug in which user cannot choose camera RAW files in the "File > Open..." dialog box.
REGRESSION: Sorting bug fix in opening a mix of JPEGs and camera RAW files via drag-and-drop.
Updates ExitTool to version 10.43.

What's new with version 1.7.2:
Improves image and video rotation function. You can rotate image or video by 90 degrees by rotating gesture on the
Trackpad. With "Rotate by Arbitrary Angle" enabled, you can zoom and rotate image simultaneously with the Trackpad.
New "Show AF Points" function (available for Canon, Nikon, Fujifilm and Sony cameras) and "Show Detected Faces"
function (available for Canon, Fujifilm, Nikon, Panasonic, Pentax, Olympus and Sony cameras). They are located under the
Tools menu.
When either or both of the above functions are enabled, zooming immediately to 100% will bring the focus or detected
face to the center of the window. You can cycle through the focus points or detected faces with the [ and ] shortcut keys.
Bug fixes for folder scanning process and sorting process.
Updates ExitTool to version 10.42.

What's new with version 1.7.1:



Improves zooming and panning performance for high resolution images (> 24MPix).

What's new with version 1.7.0:
Sorting is working again with file caching subsystem.
New "Short date/time format" option (Preferences > Appearance).
Adds folder monitor to track file system changes. Changes in Finder (such as cut-and-paste) will be reflected
automatically in ApolloOne.
Updates ExitTool to version 10.40.

What's new with version 1.6.4:
Improves support for macOS Sierra.
Updates ExitTool to version 10.36.

What's new with version 1.6.3:
Improves support for Retina Displays.

What's new with version 1.6.2:
Adds high performance file caching subsystem. Best performance is achieved with macOS 10.11 El Capitan and higher.
Updates ExitTool to version 10.33.

What's new with version 1.6.1:
Animated map panning for Interactive Google Maps.
Folder browser and File inspector behaviors have been streamlined.
Adds Help buttons in Preferences.
Updates ExitTool to version 10.31.

What's new with version 1.6.0:
Supports macOS Sierra 10.12
Interactive Google Maps (requires Google Maps Javascript API Key).
You can now update and delete GPS position data using the map interactively.
New "Scale up small images to fit" option for Slideshow in Preferences.
You can now pan around a zoomed-in image with the keyboard. Hold down the alt key and press the arrow keys.
Image can now be magnified up to 800%.
Additional keyboard shortcut keys.
You can now right click on the map area to select Apple Maps or Google Maps.
Updates ExitTool to version 10.27.

What's new with version 1.5.0:
The minimum supported version is now OS X 10.9 Mavericks.
You can now choose Apple Maps or Google Maps (right click on the grey background area to select).
VFL computation can now be turned off in Preferences.
Main window can now be made "Always on Top" under the Window menu.
You can now rotate/flip video playback - 90 degrees clockwise, counter-clockwise, flip horizontally, vertically.
New Rotate 180° for image and video playback.
New video playback controller with frame stepping and frame accurate export functions.
New experimental SubRip SRT Subtitle support.
Greatly improves Japanese and Korean translations.
Updates ExifTool to version 10.25.

What's new with version 1.4.1:
New "Edit video with" menu item with ⌘E shortcut key for quickly launching an external application for video editing.

What's new with version 1.4.0:



New "Edit with" and "Edit RAW with" menu items with ⌘E shortcut key for quickly launching an external application for
image editing. To select the external application, simply launch it once from the context menu "Open With" or "Open
Camera RAW With", and the "Edit with" or "Edit RAW with" menu choice will be set.
New ⌘R shortcut key for reopening the last viewed file at the time of app exit. New Preferences setting for reopening the
last file on startup.
New ⌘W shortcut key for closing the main window. You can restore the main window by pressing the ⌘B shortcut key.
Sort setting is now remembered and sorting is performed automatically on the next application launch.
New Dark Mode User Interface setting (available with OS X 10.10 and above).

What's new with version 1.1.1 - 1.3.0:
Inspector can now be shown in HUD-style, just like the folder browser. First select "Show Inspector" in the Tools menu,
then unselect "Floating Inspector Panel" and click the  button on the lower right hand corner of the main window to
activate.
Folder browser can now be attached as a sidecar of the main window. Just click the  button on the lower right hand
corner to activate.
Rewritten thumbnail and RAW Preview engines. They are now faster with higher image quality. It is now possible to
preview RAW files that are not supported by the Operating System.
New "High quality image scaling" setting replacing old setting of "Use GPU for image loading". Turn this setting off to
speed up image display on older Macs.
35mm Film Equivalent Focal length conversion for over 6000 digital cameras.
Add zoom percentage in the status bar.
Add zooming with Magic Mouse and 3rd party mouse with a scroll wheel. To activate the zoom function, hold down the alt
key on the keyboard and move up and down on the surface of the Magic Mouse with your finger or scroll the mouse
wheel.
Virtual Focal length on the status bar when you zoom in and out of an image. This is to simulate the use of a zoom lens to
give you an idea of the field of view with a different lens. This is shown as VFL= instead of FL=
APSC zooming will now respect the window size.
Add folder browser so user can load images quickly from any folder. Folder browser is activated by moving the mouse
pointer to the left side of the main window. A context menu is available for the folder browser. Just activate it using right
mouse click or control-mouse click.
Add "Include Hidden Files" and "Include Package Contents" to the Tools menu and context menus.
Inspector can now be attached as a sidecar of the main window. Just click the inspector button on the lower right hand
corner of the main window to activate.
Comprehensive EXIF, IPTC, MakerNotes, Photoshop and XMP information on the Inspector panel's Detailed Info page. The
information is searchable.
Inspector panel will now remember the size of the window per individual page.
Add a user preference to use GPU for loading images.
Use the highest quality Lanczos filtering for image scaling when GPU setting is turned on.
You can tag files for filtering and peform file operations on them (copy / move / trash).
Sorting by file and image properties. You can also define a two-level sort key.
Share your photos and videos via online sharing services, such as Facebook, Twitter, Sina Weibo, etc. A unique feature for
sharing just a portion of the image via zooming and panning of the image.
You can also share files via AirDrop to another Apple device.
"Open Camera RAW With" context menu while viewing JPEG files.
ApolloOne will now ask you for the library location of iPhoto and Photos applications in case the libraries are not stored in
the standard locations inside the Pictures folder.
Background threads optimization using Grand Central Dispatch (GCD).
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